aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm26
2 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 71bfeb0be5..f7e534d908 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -861,6 +861,33 @@ optimized for sparse nodes of
@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
(license license:expat)))
+(define-public go-github-com-arran4-golang-ical
+ (package
+ (name "go-github-com-arran4-golang-ical")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arran4/golang-ical")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gcn5afds1dnq3wrl4ndi4wqqwmrnvh9pdqhyv77d3cqakn82vj3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/arran4/golang-ical"))
+ (native-inputs
+ (list go-github-com-google-go-cmp
+ go-github-com-stretchr-testify))
+ (home-page "https://github.com/arran4/golang-ical")
+ (synopsis "Handle iCalenders in Go")
+ (description
+ "The @code{ical} package provides an ICS/iCalender parser and serialiser
+for Go.")
+ (license license:asl2.0)))
+
(define-public go-github-com-audriusbutkevicius-recli
(package
(name "go-github-com-audriusbutkevicius-recli")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0d2a5cd6a1..ee45190900 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8856,32 +8856,6 @@ useful during debugging, to avoid wrapping long output lines in the
terminal.")
(license license:expat)))
-(define-public go-github-com-arran4-golang-ical
- (package
- (name "go-github-com-arran4-golang-ical")
- (version "0.3.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/arran4/golang-ical")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0gcn5afds1dnq3wrl4ndi4wqqwmrnvh9pdqhyv77d3cqakn82vj3"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/arran4/golang-ical"))
- (native-inputs
- (list go-github-com-google-go-cmp
- go-github-com-stretchr-testify))
- (home-page "https://github.com/arran4/golang-ical")
- (synopsis "Handle iCalenders in Go")
- (description
- "The @code{ical} package provides an ICS/iCalender parser and
-serialiser for Go.")
- (license license:asl2.0)))
-
(define-public go-github-com-lithammer-fuzzysearch
(package
(name "go-github-com-lithammer-fuzzysearch")