aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm89
1 files changed, 89 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c157b730a5..6972e79081 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15765,3 +15765,92 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"munkres algorithm for the Assignment Problem. Python 3 port.")
(license #f)))
+
+(define-public coala-bears
+ (package
+ (name "coala-bears")
+ (version "0.11.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "coala-bears" version))
+ (sha256
+ (base32
+ "08jlf9jxch1i27kgfmqhnn8qdxzbi2v2l8fwpnc621s6br5k13wl"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-requires
+ (lambda _
+ (for-each (lambda (requirement)
+ (substitute* "bear-requirements.txt"
+ (((string-append requirement "(=|~)="))
+ (string-append requirement ">="))))
+ '("autoflake"
+ "click"
+ "eradicate"
+ "html-linter"
+ "mypy-lang"
+ "proselint"
+ "pydocstyle"
+ "pyflakes"
+ "pyroma"
+ "radon"
+ "restructuredtext-lint"
+ "rstcheck"
+ "safety"
+ "vulture"
+ "yamllint"
+ "yapf"))
+ #t)))))
+ (propagated-inputs
+ `(;;("python-aenum" ,python-aenum)
+ ;; ("python-apertium-lint" ,python-apertium-lint)
+ ("python-autoflake" ,python-autoflake)
+ ("python-autopep8" ,python-autopep8)
+ ("python-bandit" ,python-bandit)
+ ("python-click" ,python-click)
+ ("python-cmakelint" ,python-cmakelint)
+ ("coala" ,coala)
+ ("python-cppclean" ,python-cppclean)
+ ("python-cpplint" ,python-cpplint)
+ ("python-dennis" ,python-dennis)
+ ;; ("python-docutils-ast-writer"
+ ;; ,python-docutils-ast-writer)
+ ("python-eradicate" ,python-eradicate)
+ ("python-guess-language-spirit"
+ ,python-guess-language-spirit)
+ ("python-html-linter" ,python-html-linter)
+ ;; ("python-httpolice" ,python-httpolice)
+ ("python-isort" ,python-isort)
+ ;; ("python-memento-client" ,python-memento-client)
+ ("python-munkres3" ,python-munkres3)
+ ("python-mypy-lang" ,python-mypy-lang)
+ ("python-nbformat" ,python-nbformat)
+ ("python-nltk" ,python-nltk)
+ ("python-proselint" ,python-proselint)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-pydocstyle" ,python-pydocstyle)
+ ("python-pyflakes" ,python-pyflakes)
+ ("python-pylint" ,python-pylint)
+ ("python-pyroma" ,python-pyroma)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-radon" ,python-radon)
+ ("python-restructuredtext-lint"
+ ,python-restructuredtext-lint)
+ ("python-rstcheck" ,python-rstcheck)
+ ("python-safety" ,python-safety)
+ ("python-scspell3k" ,python-scspell3k)
+ ("python-vim-vint" ,python-vim-vint)
+ ("python-vulture" ,python-vulture)
+ ("python-yamllint" ,python-yamllint)
+ ("python-yapf" ,python-yapf)
+ ))
+ (home-page "http://coala.rtfd.org/")
+ (synopsis
+ "Bears for coala (Code Analysis Application)")
+ (description
+ "Bears for coala (Code Analysis Application)")
+ (license #f)))