aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-19 20:18:09 +0000
committerChristopher Baines <mail@cbaines.net>2019-03-19 20:21:54 +0000
commitbdfb6542333b81dd1c72fcbc9a9a934bce034617 (patch)
treea6c905751a64fd6f60148bf91c0f328bc0029e8a /configure.ac
parent5985b5938b0cec4621bf93063b32513438761723 (diff)
downloaddata-service-bdfb6542333b81dd1c72fcbc9a9a934bce034617.tar
data-service-bdfb6542333b81dd1c72fcbc9a9a934bce034617.tar.gz
Add support for processing branch updated emails
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e471696..138a31d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,11 @@ if test "x$have_fibers" != "xyes"; then
AC_MSG_ERROR([Guile fibers is missing; please install it.])
fi
+GUILE_MODULE_AVAILABLE([have_email], [(email email)])
+if test "x$have_email" != "xyes"; then
+ AC_MSG_ERROR([Guile email is missing; please install it.])
+fi
+
guilemoduledir="${datarootdir}/guile/site/${GUILE_EFFECTIVE_VERSION}"
AC_SUBST([guilemoduledir])
AC_SUBST([GUILE_EFFECTIVE_VERSION])
@@ -35,6 +40,7 @@ AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([guix-data-service/config.scm])
AC_CONFIG_FILES([scripts/guix-data-service], [chmod +x scripts/guix-data-service])
AC_CONFIG_FILES([scripts/guix-data-service-process-jobs], [chmod +x scripts/guix-data-service-process-jobs])
+AC_CONFIG_FILES([scripts/guix-data-service-process-branch-updated-email], [chmod +x scripts/guix-data-service-process-branch-updated-email])
AC_CONFIG_FILES([scripts/guix-data-service-query-build-servers], [chmod +x scripts/guix-data-service-query-build-servers])
AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])