aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-06 16:14:44 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-07 22:26:57 +0000
commit5a9262b38d506008b21fd73eb8f7c3046b47de92 (patch)
tree5b18de9c664bac282bfa5f798a4a46304dfe5f03 /configure.ac
downloaddata-service-5a9262b38d506008b21fd73eb8f7c3046b47de92.tar
data-service-5a9262b38d506008b21fd73eb8f7c3046b47de92.tar.gz
Initial commit
This is a service designed to provide information about Guix. At the moment, this initial prototype gathers up information about packages, the associated metadata and derivations. The initial primary use case is to compare two different revisions of Guix, detecting which packages are new, no longer present, updated or otherwise different. It's based on the Mumi project. [1]: https://git.elephly.net/software/mumi.git
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8eb14ab
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,40 @@
+dnl -*- Autoconf -*-
+
+AC_INIT([guix-data-service], [m4_translit(m4_esyscmd([cat VERSION]),m4_newline)])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([gnu color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+GUILE_PKG([2.2])
+GUILE_PROGS
+if test "x$GUILD" = "x"; then
+ AC_MSG_ERROR(['guild' binary not found; please check your guile-2.2 installation.])
+fi
+
+GUILE_MODULE_AVAILABLE([have_json], [(json)])
+if test "x$have_json" != "xyes"; then
+ AC_MSG_ERROR([Guile-JSON is missing; please install it.])
+fi
+
+GUILE_MODULE_AVAILABLE([have_guile_squee], [(squee)])
+if test "x$have_guile_squee" != "xyes"; then
+ AC_MSG_ERROR([Guile-Squee is missing; please install it.])
+fi
+
+GUILE_MODULE_AVAILABLE([have_fibers], [(fibers web server)])
+if test "x$have_fibers" != "xyes"; then
+ AC_MSG_ERROR([Guile fibers is missing; please install it.])
+fi
+
+guilemoduledir="${datarootdir}/guile/site/${GUILE_EFFECTIVE_VERSION}"
+AC_SUBST([guilemoduledir])
+AC_SUBST([GUILE_EFFECTIVE_VERSION])
+
+dnl Substitute placeholders to generate these target files
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([guix-data-service/config.scm])
+AC_CONFIG_FILES([scripts/guix-data-service], [chmod +x scripts/guix-data-service])
+AC_CONFIG_FILES([scripts/guix-data-service-process-jobs], [chmod +x scripts/guix-data-service-process-jobs])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+AC_OUTPUT