aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-07-12 19:57:24 +0100
committerChristopher Baines <mail@cbaines.net>2019-07-12 19:57:24 +0100
commit09d927cb99d488b1d9024ec7592b900b6645d065 (patch)
treef27ea55a225eb18184200c259c2ce1bc6365e721 /configure.ac
parenta6bd46b829070fca8843bc0155e5bf2b71d422dd (diff)
downloaddata-service-09d927cb99d488b1d9024ec7592b900b6645d065.tar
data-service-09d927cb99d488b1d9024ec7592b900b6645d065.tar.gz
Add a process-job command
This allows easily processing an individual job by id. This may be useful to use manually, but also when processing jobs in parallel, as forking doesn't work well with the libpq library used by squee.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a50d90b..deace04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,7 @@ dnl Substitute placeholders to generate these target files
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([guix-data-service/config.scm])
AC_CONFIG_FILES([scripts/guix-data-service], [chmod +x scripts/guix-data-service])
+AC_CONFIG_FILES([scripts/guix-data-service-process-job], [chmod +x scripts/guix-data-service-process-job])
AC_CONFIG_FILES([scripts/guix-data-service-process-jobs], [chmod +x scripts/guix-data-service-process-jobs])
AC_CONFIG_FILES([scripts/guix-data-service-process-branch-updated-email], [chmod +x scripts/guix-data-service-process-branch-updated-email])
AC_CONFIG_FILES([scripts/guix-data-service-query-build-servers], [chmod +x scripts/guix-data-service-query-build-servers])