aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-05-05 20:06:28 +0100
committerChristopher Baines <mail@cbaines.net>2019-05-05 20:06:28 +0100
commit5028dfe706856d11246a7338dfd47d4035d8fb25 (patch)
tree9e13cf7e390e345a42f0c3bfd4d30537e12bc52f /Makefile.am
parentce4c3c6ed3979e54a8d5db6514bf4ed87de8b707 (diff)
downloaddata-service-5028dfe706856d11246a7338dfd47d4035d8fb25.tar
data-service-5028dfe706856d11246a7338dfd47d4035d8fb25.tar.gz
Start to handle information about Git branches
Add some new pages /branches and /branch/... as well as a new git_branches table. Also extend the email processing to enter the branch information in to the database.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f61284a..1730c2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,6 +42,7 @@ SOURCES = \
guix-data-service/model/build-status.scm \
guix-data-service/model/build.scm \
guix-data-service/model/derivation.scm \
+ guix-data-service/model/git-branch.scm \
guix-data-service/model/git-repository.scm \
guix-data-service/model/guix-revision-package-derivation.scm \
guix-data-service/model/guix-revision.scm \
@@ -60,7 +61,9 @@ TEST_EXTENSIONS = .scm
TESTS = \
tests/model-derivation.scm \
- tests/model-git-repository.scm
+ tests/model-git-branch.scm \
+ tests/model-git-repository.scm \
+ tests/branch-updated-emails.scm
AM_TESTS_ENVIRONMENT = abs_top_srcdir="$(abs_top_srcdir)"