aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-11-10 16:06:45 +0000
committerChristopher Baines <mail@cbaines.net>2022-11-11 10:35:09 +0000
commit1fb291be40172d9337c5bbec3119fbe1b908f7df (patch)
tree9d37e03ae9de95bb84a3989ad678437eca19707a /Makefile.am
parent95064d39a337da9f2eb7d5675e0e511301466f77 (diff)
downloaddata-service-1fb291be40172d9337c5bbec3119fbe1b908f7df.tar
data-service-1fb291be40172d9337c5bbec3119fbe1b908f7df.tar.gz
Add support for incrementally tracking blocked builds
This will hopefully provide a less expensive way of finding out if a scheduled build is probably blocked by other builds failing or being canceled. By working this out when the build events are recieved, it should be more feasible to include information about whether builds are likely blocked or not in various places (e.g. revision comparisons).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d97045..193ec7c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,6 +82,7 @@ SOURCES = \
guix-data-service/model/build-server.scm \
guix-data-service/model/build-server-token-seed.scm \
guix-data-service/model/build-status.scm \
+ guix-data-service/model/blocked-builds.scm \
guix-data-service/model/build.scm \
guix-data-service/model/channel-instance.scm \
guix-data-service/model/channel-news.scm \