aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-14 01:24:43 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-14 01:28:49 +0100
commit84de473132218f313b2e71342ff209b8d9db3e80 (patch)
tree6574bf62330b732a7cb254b5ab41abde1954731f /tests
parent4a6ca998244f280958207e8ac15bae6e75943aca (diff)
downloadguix-84de473132218f313b2e71342ff209b8d9db3e80.tar
guix-84de473132218f313b2e71342ff209b8d9db3e80.tar.gz
tests: guix-shell-export-manifest: Fix pyproject-build-system python test.
This is a follow-up to commit fdc0fefd46a45b70784a4e3f8900cbe593426a9e build-system/pyproject: Use python-sans-pip-wrapper as default-python. * tests/guix-shell-export-manifest.sh: Grep for python-sans-pip-wrapper, which is the python now used by the pyproject-build-system. Change-Id: I5f44e07544f80973fa6b306b2dcdf42ac3b56ad6
Diffstat (limited to 'tests')
-rw-r--r--tests/guix-shell-export-manifest.sh3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/guix-shell-export-manifest.sh b/tests/guix-shell-export-manifest.sh
index 6c42c40f3b..fd0b4e47a9 100644
--- a/tests/guix-shell-export-manifest.sh
+++ b/tests/guix-shell-export-manifest.sh
@@ -1,5 +1,6 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2022 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
#
# This file is part of GNU Guix.
#
@@ -83,7 +84,7 @@ guix build -m "$manifest" -d | \
guix shell --export-manifest -D guile -D python-itsdangerous > "$manifest"
guix build -m "$manifest" -d | grep "$(guix build libffi -d)"
guix build -m "$manifest" -d | \
- grep "$(guix build -e '(@ (gnu packages python) python)' -d)"
+ grep "$(guix build -e '(@ (gnu packages python) python-sans-pip-wrapper)' -d)"
# Test various combinations to make sure generated code uses interfaces
# correctly.