aboutsummaryrefslogtreecommitdiff
path: root/tests/union.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-04 22:04:41 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-04 22:04:41 +0100
commit18633d4f350160c2eb6f5101a628010322336e91 (patch)
treeb4ecda9841422044bb583026e129624dd47f3c8f /tests/union.scm
parent9d9e64508186e5f9efbe45302134cd709b25e47b (diff)
downloadguix-18633d4f350160c2eb6f5101a628010322336e91.tar
guix-18633d4f350160c2eb6f5101a628010322336e91.tar.gz
distro: Move bootstrap packages to (distro packages bootstrap).
* distro/packages/base.scm (glibc-dynamic-linker, %bootstrap-guile, bootstrap-origin, package-from-tarball, %bootstrap-base-url, %bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc, %bootstrap-gcc, %bootstrap-inputs, package-with-bootstrap-guile): Move to ... * distro/packages/bootstrap.scm: ... here. New file. * Makefile.am (MODULES): Add it. * tests/builders.scm: Use (distro packages bootstrap). (%bootstrap-guile): Remove. * tests/packages.scm: Likewise. * tests/union.scm: Likewise, and remove @@ to access %bootstrap-inputs. * tests/derivations.scm: Use (distro packages bootstrap) and remove @@ to access %bootstrap-coreutils&co. * HACKING (When the platform is supported by Nixpkgs): Update accordingly.
Diffstat (limited to 'tests/union.scm')
-rw-r--r--tests/union.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/tests/union.scm b/tests/union.scm
index f8a58d5952..73b95c49b8 100644
--- a/tests/union.scm
+++ b/tests/union.scm
@@ -25,6 +25,7 @@
#:use-module (guix build union)
#:use-module ((guix build utils)
#:select (with-directory-excursion directory-exists?))
+ #:use-module (distro packages bootstrap)
#:use-module (srfi srfi-64)
#:use-module (ice-9 match))
@@ -33,9 +34,6 @@
(define %store
(false-if-exception (open-connection)))
-(define %bootstrap-guile
- (@@ (distro packages base) %bootstrap-guile))
-
(when %store
;; By default, use %BOOTSTRAP-GUILE for the current system.
(let ((drv (package-derivation %store %bootstrap-guile)))
@@ -72,7 +70,7 @@
(let* ((inputs (map (match-lambda
((name package)
`(,name ,(package-derivation %store package))))
- (@@ (distro packages base) %bootstrap-inputs)))
+ %bootstrap-inputs))
(builder `(begin
(use-modules (guix build union))
(union-build (assoc-ref %outputs "out")