aboutsummaryrefslogtreecommitdiff
path: root/tests/ui.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-09-10 12:37:36 +0300
committerAlex Kost <alezost@gmail.com>2015-09-18 21:42:06 +0300
commit88981dd3e2b5bb3ae1ad7e54648c038226282a61 (patch)
tree2f0785125cc225f02cfb0acb79f1c0c592e1f0db /tests/ui.scm
parentb2cb869cf928aa0aba7716103548b49af852d6e6 (diff)
downloadguix-88981dd3e2b5bb3ae1ad7e54648c038226282a61.tar
guix-88981dd3e2b5bb3ae1ad7e54648c038226282a61.tar.gz
Add (guix scripts).
* guix/ui.scm: Add missing copyright lines. (args-fold*, environment-build-options, %default-argument-handler, parse-command-line): Move to ... * guix/scripts.scm: ...here. New file. * guix/scripts/archive.scm: Use it. * guix/scripts/build.scm: Likewise. * guix/scripts/download.scm: Likewise. * guix/scripts/edit.scm: Likewise. * guix/scripts/environment.scm: Likewise. * guix/scripts/gc.scm: Likewise. * guix/scripts/graph.scm: Likewise. * guix/scripts/hash.scm: Likewise. * guix/scripts/import/cpan.scm: Likewise. * guix/scripts/import/cran.scm: Likewise. * guix/scripts/import/elpa.scm: Likewise. * guix/scripts/import/gem.scm: Likewise. * guix/scripts/import/gnu.scm: Likewise. * guix/scripts/import/hackage.scm: Likewise. * guix/scripts/import/nix.scm: Likewise. * guix/scripts/import/pypi.scm: Likewise. * guix/scripts/lint.scm: Likewise. * guix/scripts/package.scm: Likewise. * guix/scripts/publish.scm: Likewise. * guix/scripts/pull.scm: Likewise. * guix/scripts/refresh.scm: Likewise. * guix/scripts/size.scm: Likewise. * guix/scripts/system.scm: Likewise. * tests/ui.scm (with-environment-variable, "parse-command-line", "parse-command-line and --no options"): Move to ... * tests/scripts.scm: ...here. New file. * Makefile.am (MODULES): Add guix/scripts.scm. (SCM_TESTS): Add tests/scripts.scm. * po/guix/POTFILES.in: Add guix/scripts.scm.
Diffstat (limited to 'tests/ui.scm')
-rw-r--r--tests/ui.scm40
1 files changed, 0 insertions, 40 deletions
diff --git a/tests/ui.scm b/tests/ui.scm
index 1478fe213e..25fc709431 100644
--- a/tests/ui.scm
+++ b/tests/ui.scm
@@ -22,8 +22,6 @@
#:use-module (guix profiles)
#:use-module (guix store)
#:use-module (guix derivations)
- #:use-module ((guix scripts build)
- #:select (%standard-build-options))
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-11)
#:use-module (srfi srfi-19)
@@ -54,43 +52,9 @@ interface, and powerful string processing.")
(item "/gnu/store/...")
(output "out")))
-(define-syntax-rule (with-environment-variable variable value body ...)
- "Run BODY with VARIABLE set to VALUE."
- (let ((orig (getenv variable)))
- (dynamic-wind
- (lambda ()
- (setenv variable value))
- (lambda ()
- body ...)
- (lambda ()
- (if orig
- (setenv variable orig)
- (unsetenv variable))))))
-
(test-begin "ui")
-(test-equal "parse-command-line"
- '((argument . "bar") (argument . "foo")
- (cores . 10) ;takes precedence
- (substitutes? . #f) (keep-failed? . #t)
- (max-jobs . 77) (cores . 42))
-
- (with-environment-variable "GUIX_BUILD_OPTIONS" "-c 42 -M 77"
- (parse-command-line '("--keep-failed" "--no-substitutes"
- "--cores=10" "foo" "bar")
- %standard-build-options
- (list '()))))
-
-(test-equal "parse-command-line and --no options"
- '((argument . "foo")
- (substitutes? . #f)) ;takes precedence
-
- (with-environment-variable "GUIX_BUILD_OPTIONS" "--no-substitutes"
- (parse-command-line '("foo")
- %standard-build-options
- (list '((substitutes? . #t))))))
-
(test-assert "fill-paragraph"
(every (lambda (column)
(every (lambda (width)
@@ -282,7 +246,3 @@ Second line" 24))
(exit (= (test-runner-fail-count (test-runner-current)) 0))
-
-;;; Local Variables:
-;;; eval: (put 'with-environment-variable 'scheme-indent-function 2)
-;;; End: