aboutsummaryrefslogtreecommitdiff
path: root/tests/store.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-21 22:42:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-21 22:46:55 +0100
commit953c2de7061f18f55d8c51b72eb24945f436e80e (patch)
treebabc2599184d2cb697c8d1a6fda27151a50383c8 /tests/store.scm
parentd1451fa0d0b27a20ef3a1b3fe8d53a995f0c4d85 (diff)
downloadguix-953c2de7061f18f55d8c51b72eb24945f436e80e.tar
guix-953c2de7061f18f55d8c51b72eb24945f436e80e.tar.gz
tests: Disable test for freed disk space that fails on Btrfs.
This is a follow-up to commit 40e89f5be609045bc2666cc16a4ef80bb7f84095. * tests/store.scm ("dead path can be explicitly collected"): Don't check that (> freed 0). * gnu/packages/package-management.scm (guix)[arguments]<#:phases>: Remove workaround for the same problem.
Diffstat (limited to 'tests/store.scm')
-rw-r--r--tests/store.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/store.scm b/tests/store.scm
index 45aeb329b0..fdf3be33f6 100644
--- a/tests/store.scm
+++ b/tests/store.scm
@@ -180,7 +180,9 @@
(random-text) '())))
(let-values (((paths freed) (delete-paths %store (list p))))
(and (equal? paths (list p))
- (> freed 0)
+ ;; XXX: On some file systems (notably Btrfs), freed
+ ;; may return 0. See <https://bugs.gnu.org/29363>.
+ ;;(> freed 0)
(not (file-exists? p))))))
(test-assert "add-text-to-store vs. delete-paths"