aboutsummaryrefslogtreecommitdiff
path: root/tests/pypi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-04-30 22:30:49 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-30 22:30:49 +0200
commit1ad52e2eebbd19963319a8530d413b1956ec5de7 (patch)
tree30361952f32d5f59084319f0517c9f9b5585a16c /tests/pypi.scm
parenta27e0d4533ec8833e83530e1b362e8ceee6a86e3 (diff)
downloadguix-1ad52e2eebbd19963319a8530d413b1956ec5de7.tar
guix-1ad52e2eebbd19963319a8530d413b1956ec5de7.tar.gz
import: pypi: Adjust tests for new build system.
This is a followup to cb8d080349a0691f4d563fcdd7bc8d8c40d0d88b. * tests/pypi.scm ("pypi->guix-package, no wheel") ("pypi->guix-package, wheels") ("pypi->guix-package, no usable requirement file.") ("pypi->guix-package, package name contains \"-\" followed by digits"): Replace 'python-build-system' by 'pyproject-build-system'.
Diffstat (limited to 'tests/pypi.scm')
-rw-r--r--tests/pypi.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/pypi.scm b/tests/pypi.scm
index 88bb0a3116..1ddcc542ff 100644
--- a/tests/pypi.scm
+++ b/tests/pypi.scm
@@ -255,7 +255,7 @@ Requires-Dist: pytest (>=3.1.0); extra == 'testing'
('sha256
('base32
(? string? hash)))))
- ('build-system 'python-build-system)
+ ('build-system 'pyproject-build-system)
('propagated-inputs ('list 'python-bar 'python-foo))
('native-inputs ('list 'python-pytest))
('home-page "http://example.com")
@@ -323,7 +323,7 @@ Requires-Dist: pytest (>=3.1.0); extra == 'testing'
('sha256
('base32
(? string? hash)))))
- ('build-system 'python-build-system)
+ ('build-system 'pyproject-build-system)
('propagated-inputs ('list 'python-bar 'python-baz))
('native-inputs ('list 'python-pytest))
('home-page "http://example.com")
@@ -371,7 +371,7 @@ Requires-Dist: pytest (>=3.1.0); extra == 'testing'
('sha256
('base32
(? string? hash)))))
- ('build-system 'python-build-system)
+ ('build-system 'pyproject-build-system)
('home-page "http://example.com")
('synopsis "summary")
('description "summary")
@@ -420,7 +420,7 @@ Requires-Dist: pytest (>=3.1.0); extra == 'testing'
('base32
(? string? hash)))))
('properties ('quote (("upstream-name" . "foo-99"))))
- ('build-system 'python-build-system)
+ ('build-system 'pyproject-build-system)
('propagated-inputs ('list 'python-bar 'python-foo))
('native-inputs ('list 'python-pytest))
('home-page "http://example.com")