aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-system.sh
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-04-13 17:15:10 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-06-08 13:51:19 +0200
commit59bcffa314171294278444aad4b7012abe50257a (patch)
treefb3da83f672c4c08d7af60950a47d96cae5d16f7 /tests/guix-system.sh
parente6cd8581c192f739712013874dfa9690522ea9f1 (diff)
downloadguix-59bcffa314171294278444aad4b7012abe50257a.tar
guix-59bcffa314171294278444aad4b7012abe50257a.tar.gz
system: examples: Add bare-hurd.tmpl.
* gnu/system/hurd.scm (%hurd-def%hurd-default-operating-system-kernel, %hurd-default-operating-system): New exported variables. * gnu/system/examples/bare-hurd.tmpl: New file. * Makefile.am (EXAMPLES): Add it. * tests/guix-system.sh: Add --target=i586-pc-gnu when testing it.
Diffstat (limited to 'tests/guix-system.sh')
-rw-r--r--tests/guix-system.sh7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/guix-system.sh b/tests/guix-system.sh
index 3a831cba1d..0e22686a34 100644
--- a/tests/guix-system.sh
+++ b/tests/guix-system.sh
@@ -307,7 +307,12 @@ guix system search anonym network | grep "^name: tor"
# Verify that the examples can be built.
for example in gnu/system/examples/*.tmpl; do
- guix system -n disk-image "$example"
+ if echo "$example" | grep hurd; then
+ target="--target=i586-pc-gnu"
+ else
+ target=
+ fi
+ guix system -n disk-image $target "$example"
done
# Verify that the disk image types can be built.