aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-package.sh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-01 13:16:27 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-01 13:16:41 +0100
commit299112d36e872d98896bf8dec281c34d9adad06e (patch)
tree5642b1b322758f1e9919c93a89e793fad181ab81 /tests/guix-package.sh
parentaa92cf980cab9f085df11c79c4b27d2b8b0d88aa (diff)
downloadguix-299112d36e872d98896bf8dec281c34d9adad06e.tar
guix-299112d36e872d98896bf8dec281c34d9adad06e.tar.gz
guix-package: Report `--search' matches in recutils format.
* guix/ui.scm (fill-paragraph, string->recutils, package->recutils): New procedures. * guix-package.in (guix-package)[process-query]: Use `package->recutils' to display package meta-data. * tests/guix-package.sh: Adjust test. * tests/ui.scm: New file. * Makefile.am (TESTS): Add it. * doc/guix.texi (Invoking guix-package): Adjust `--search' documentation, and give an example.
Diffstat (limited to 'tests/guix-package.sh')
-rw-r--r--tests/guix-package.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/guix-package.sh b/tests/guix-package.sh
index 0b31b55103..42a1f8da96 100644
--- a/tests/guix-package.sh
+++ b/tests/guix-package.sh
@@ -70,7 +70,7 @@ then
test "`guix-package -p "$profile" -I 'g.*e' | cut -f1`" = "guile-bootstrap"
# Search.
- test "`guix-package -s "GNU Hello" | cut -f1`" = "hello"
+ test "`guix-package -s "GNU Hello" | grep ^name:`" = "name: hello"
test "`guix-package -s "n0t4r341p4ck4g3"`" = ""
# Remove a package.