aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-graph.sh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-27 00:36:41 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-27 00:49:23 +0200
commit888569161c0cb55a2700806aded7128cfe605857 (patch)
tree116f9191b62d4a09575d6e811c906f54d3828241 /tests/guix-graph.sh
parent12e5b26643e2269e8f30d8399886d4302c3c09d1 (diff)
downloadguix-888569161c0cb55a2700806aded7128cfe605857.tar
guix-888569161c0cb55a2700806aded7128cfe605857.tar.gz
Add 'guix graph'.
* guix/scripts/graph.scm, tests/graph.scm, tests/guix-graph.sh, doc/images/coreutils-bag-graph.dot, doc/images/coreutils-graph.dot: New files. * Makefile.am (MODULES): Add guix/scripts/graph.scm. (SH_TESTS): Add tests/guix-graph.sh. (SCM_TESTS): Add tests/graph.scm. * doc.am (DOT_FILES, DOT_VECTOR_GRAPHICS): New variables. (EXTRA_DIST): Use them. (dist_infoimage_DATA): Use $(DOT_FILES). (pdf-local, info-local, ps-local): Likewise. * doc/guix.texi (Packages with Multiple Outputs): Add cross-reference to 'guix graph'. (Invoking guix gc): Likewise. (Invoking guix graph): New section.
Diffstat (limited to 'tests/guix-graph.sh')
-rw-r--r--tests/guix-graph.sh34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/guix-graph.sh b/tests/guix-graph.sh
new file mode 100644
index 0000000000..199258a9b8
--- /dev/null
+++ b/tests/guix-graph.sh
@@ -0,0 +1,34 @@
+# GNU Guix --- Functional package management for GNU
+# Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+#
+# This file is part of GNU Guix.
+#
+# GNU Guix is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+#
+# GNU Guix is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+#
+# Test the 'guix graph' command-line utility.
+#
+
+guix graph --version
+
+for package in guile-bootstrap coreutils python
+do
+ for graph in package bag-emerged bag
+ do
+ guix graph -t "$graph" "$package" | grep "$package"
+ done
+done
+
+guix build guile-bootstrap
+guix graph -t references guile-bootstrap | grep guile-bootstrap