aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-download.sh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-08 00:13:25 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-08 00:13:25 +0100
commit37d19403e78e8dfab24a471bee7c8ee17346e43c (patch)
tree11dec895f346457b90aa7a4d05654d41f95b3544 /tests/guix-download.sh
parent912209ee61ced92c3246da78ed9991781fa6bf2d (diff)
downloadguix-37d19403e78e8dfab24a471bee7c8ee17346e43c.tar
guix-37d19403e78e8dfab24a471bee7c8ee17346e43c.tar.gz
guix-download: Error out when the HTTP response code is not 200.
* guix-download.in (http-fetch): Leave with an error message when RESPONSE's code is not 200. * tests/guix-download.sh: New file. * Makefile.am (TESTS): Add it.
Diffstat (limited to 'tests/guix-download.sh')
-rw-r--r--tests/guix-download.sh27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/guix-download.sh b/tests/guix-download.sh
new file mode 100644
index 0000000000..74ef48ba4b
--- /dev/null
+++ b/tests/guix-download.sh
@@ -0,0 +1,27 @@
+# Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+# Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+#
+# This file is part of Guix.
+#
+# Guix is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+#
+# Guix is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+#
+# Test the `guix-download' command-line utility.
+#
+
+guix-download --version
+
+# Make sure it fails here.
+if guix-download http://www.example.com/does-not-exist
+then false; else true; fi