aboutsummaryrefslogtreecommitdiff
path: root/tests/gnu-maintenance.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2015-10-26 23:47:24 +0100
committerMathieu Lirzin <mthl@gnu.org>2016-04-03 14:19:09 +0200
commita9edb211e733b8b34e67ec3b4450567e9376986f (patch)
tree9f441abf268b24b2deb928d7880aa974e434672f /tests/gnu-maintenance.scm
parente25f017422899c3e43cf42e254f46053bf4c4243 (diff)
downloadguix-a9edb211e733b8b34e67ec3b4450567e9376986f.tar
guix-a9edb211e733b8b34e67ec3b4450567e9376986f.tar.gz
build: Add a Guile custom test driver using SRFI-64.
Before that '.log' files for scheme tests were fragmented and not included in test-suite.log. This unifies the semantics of SRFI-64 API with Automake test suite. * build-aux/test-driver.scm: New file. * Makefile.am (SCM_LOG_DRIVER, AM_SCM_LOG_DRIVER_FLAGS): New variables. (SCM_LOG_COMPILER, AM_SCM_LOG_FLAGS): Delete variables. (AM_TESTS_ENVIRONMENT): Set GUILE_AUTO_COMPILE to 0. * test-env.in: Silence guix-daemon. * doc/guix.texi (Running the Test Suite): Describe how to display the detailed results. Bug reports require only 'test-suite.log' file. * tests/base32.scm, tests/build-utils.scm, tests/builders.scm, tests/challenge.scm, tests/cpan.scm, tests/cpio.scm, tests/cran.scm, tests/cve.scm, tests/derivations.scm, tests/elpa.scm, tests/file-systems.scm, tests/gem.scm, tests/gexp.scm, tests/gnu-maintenance.scm, tests/grafts.scm, tests/graph.scm, tests/gremlin.scm, tests/hackage.scm, tests/hash.scm, tests/import-utils.scm, tests/lint.scm, tests/monads.scm, tests/nar.scm, tests/packages.scm, tests/pk-crypto.scm, tests/pki.scm, tests/profiles.scm, tests/publish.scm, tests/pypi.scm, tests/records.scm, tests/scripts-build.scm, tests/scripts.scm, tests/services.scm, tests/sets.scm, tests/size.scm, tests/snix.scm, tests/store.scm, tests/substitute.scm, tests/syscalls.scm, tests/system.scm, tests/ui.scm, tests/union.scm, tests/upstream.scm, tests/utils.scm: Don't exit at the end of test groups. * tests/containers.scm: Likewise. Use 'test-skip' instead of exiting with error code 77.
Diffstat (limited to 'tests/gnu-maintenance.scm')
-rw-r--r--tests/gnu-maintenance.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/tests/gnu-maintenance.scm b/tests/gnu-maintenance.scm
index e7296137dc..4f2f1ae943 100644
--- a/tests/gnu-maintenance.scm
+++ b/tests/gnu-maintenance.scm
@@ -39,6 +39,3 @@
("gnutls" "gnutls-3.2.18-w32.zip")))))
(test-end)
-
-
-(exit (= (test-runner-fail-count (test-runner-current)) 0))