aboutsummaryrefslogtreecommitdiff
path: root/tests/file-systems.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-14 15:06:46 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-14 15:24:20 +0200
commit661a1d7924e174a28e0e21bf516aa1a8a44dad73 (patch)
treee794ceca18881f189fa0be3a2477cf7a9ccd0182 /tests/file-systems.scm
parent0ec5ee94861980a6957d210adf1903ea96202dd9 (diff)
downloadguix-661a1d7924e174a28e0e21bf516aa1a8a44dad73.tar
guix-661a1d7924e174a28e0e21bf516aa1a8a44dad73.tar.gz
file-systems: Allow users to specify file system UUIDs as strings.
Fixes <http://bugs.gnu.org/19778>. Reported by Mark H Weaver <mhw@netris.org>. * gnu/system/file-systems.scm (%uuid-rx): New variable. (string->uuid): New procedure. (uuid): New macro. * tests/file-systems.scm: New file. * Makefile.am (SCM_TESTS): Add it. * doc/guix.texi (File Systems): Give an example of UUID.
Diffstat (limited to 'tests/file-systems.scm')
-rw-r--r--tests/file-systems.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/tests/file-systems.scm b/tests/file-systems.scm
new file mode 100644
index 0000000000..d445b4971f
--- /dev/null
+++ b/tests/file-systems.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-file-systems)
+ #:use-module (gnu system file-systems)
+ #:use-module (srfi srfi-64)
+ #:use-module (rnrs bytevectors))
+
+;; Test the (gnu system file-systems) module.
+
+(test-begin "file-systems")
+
+(test-equal "uuid->string"
+ "c5307e6b-d1ba-499d-89c5-cb0b143577c4"
+ (uuid->string
+ #vu8(197 48 126 107 209 186 73 157 137 197 203 11 20 53 119 196)))
+
+(test-equal "string->uuid"
+ '(16 "4dab5feb-d176-45de-b287-9b0a6e4c01cb")
+ (let ((uuid (string->uuid "4dab5feb-d176-45de-b287-9b0a6e4c01cb")))
+ (list (bytevector-length uuid) (uuid->string uuid))))
+
+(test-assert "uuid"
+ (let ((str "4dab5feb-d176-45de-b287-9b0a6e4c01cb"))
+ (bytevector=? (uuid "4dab5feb-d176-45de-b287-9b0a6e4c01cb")
+ (string->uuid "4dab5feb-d176-45de-b287-9b0a6e4c01cb"))))
+
+(test-end)
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))