aboutsummaryrefslogtreecommitdiff
path: root/tests/builders.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2018-09-09 11:54:27 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2018-09-22 22:40:12 +0200
commita2b2070b679ff7e92d856c7d6775f5f67ce4792d (patch)
treeb04f8eb6a1bf8e848b30c8ecdb1b779c4309132b /tests/builders.scm
parent985d542e028517b2888fa61831233a2b60dc7d48 (diff)
downloadguix-a2b2070b679ff7e92d856c7d6775f5f67ce4792d.tar
guix-a2b2070b679ff7e92d856c7d6775f5f67ce4792d.tar.gz
bootstrap: %bootstrap-inputs: Wrap input lists into thunks.
* gnu/packages/bootstrap.scm (%bootstrap-inputs): Change to procedure. Update users; prepares for Mes bootstrap. * gnu/packages/commencement.scm (%boot0-inputs, %boot1-inputs, %boot2-inputs, %boot3-inputs, %boot4-inputs, %boot5-inputs, %boot-6-inputs): Change to procedure. Update users. * tests/builders.scm (%bootstrap-inputs, %bootstrap-search-paths): Make a procedure, filter on package?. Update users.
Diffstat (limited to 'tests/builders.scm')
-rw-r--r--tests/builders.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/tests/builders.scm b/tests/builders.scm
index 8b8ef013e7..b2d8a7c6b2 100644
--- a/tests/builders.scm
+++ b/tests/builders.scm
@@ -28,7 +28,8 @@
#:use-module (gcrypt hash)
#:use-module (guix tests)
#:use-module ((guix packages)
- #:select (package-derivation package-native-search-paths))
+ #:select (package?
+ package-derivation package-native-search-paths))
#:use-module (gnu packages bootstrap)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1)
@@ -39,7 +40,7 @@
(define %store
(open-connection-for-tests))
-(define %bootstrap-inputs
+(define (%bootstrap-inputs)
;; Use the bootstrap inputs so it doesn't take ages to run these tests.
;; This still involves building Make, Diffutils, and Findutils.
;; XXX: We're relying on the higher-level `package-derivations' here.
@@ -47,14 +48,18 @@
(map (match-lambda
((name package)
(list name (package-derivation %store package))))
- (@@ (gnu packages commencement) %boot0-inputs))))
+ (filter
+ (compose package? cadr)
+ ((@@ (gnu packages commencement) %boot0-inputs))))))
-(define %bootstrap-search-paths
+(define (%bootstrap-search-paths)
;; Search path specifications that go with %BOOTSTRAP-INPUTS.
(append-map (match-lambda
- ((name package _ ...)
- (package-native-search-paths package)))
- (@@ (gnu packages commencement) %boot0-inputs)))
+ ((name package _ ...)
+ (package-native-search-paths package)))
+ (filter
+ (compose package? cadr)
+ ((@@ (gnu packages commencement) %boot0-inputs)))))
(define url-fetch*
(store-lower url-fetch))
@@ -104,9 +109,9 @@
#:guile %bootstrap-guile))
(build (gnu-build %store "hello-2.8"
`(("source" ,tarball)
- ,@%bootstrap-inputs)
+ ,@(%bootstrap-inputs))
#:guile %bootstrap-guile
- #:search-paths %bootstrap-search-paths))
+ #:search-paths (%bootstrap-search-paths)))
(out (derivation->output-path build)))
(and (build-derivations %store (list (pk 'hello-drv build)))
(valid-path? %store out)