aboutsummaryrefslogtreecommitdiff
path: root/tests/build-emacs-utils.scm
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@posteo.net>2022-06-05 19:51:42 +0000
committerLudovic Courtès <ludo@gnu.org>2022-06-17 23:39:31 +0200
commitf8275916fc6fcb3dd9bd8ef7dc4ddce2dca98c7d (patch)
treea888f9cbbf8b72deed9e9de4a5700abe0eb6c761 /tests/build-emacs-utils.scm
parent6013f808102e7e2093b41fc71324cdd89bb607a0 (diff)
downloadguix-f8275916fc6fcb3dd9bd8ef7dc4ddce2dca98c7d.tar
guix-f8275916fc6fcb3dd9bd8ef7dc4ddce2dca98c7d.tar.gz
guix: emacs-utils: Add emacs-batch-script.
* guix/build/emacs-utils.scm (emacs-batch-script): New procedure. * tests/build-emacs-utils.scm: New file. * Makefile.am (TESTS): Add `tests/build-emacs-utils.scm'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'tests/build-emacs-utils.scm')
-rw-r--r--tests/build-emacs-utils.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/tests/build-emacs-utils.scm b/tests/build-emacs-utils.scm
new file mode 100644
index 0000000000..27cff46c38
--- /dev/null
+++ b/tests/build-emacs-utils.scm
@@ -0,0 +1,43 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+(define-module (test build-emacs-utils)
+ #:use-module (guix tests)
+ #:use-module (guix build emacs-utils)
+ #:use-module (guix build utils)
+ #:use-module ((guix utils)
+ #:select (call-with-temporary-directory))
+ #:use-module (srfi srfi-34)
+ #:use-module (srfi srfi-64))
+
+(test-begin "build-emacs-utils")
+;; Only run the following tests if emacs is present.
+(test-skip (if (which "emacs") 0 2))
+
+(test-equal "emacs-batch-script: print foo from emacs"
+ "foo"
+ (emacs-batch-script '(princ "foo")))
+
+(test-assert "emacs-batch-script: raise &emacs-batch-error on failure"
+ (guard (c ((emacs-batch-error? c)
+ (string-contains (emacs-batch-error-message c)
+ "Lisp error: (wrong-type-argument numberp \"three\")")))
+ (emacs-batch-script '(mapcar 'number-to-string (list 1 2 "three")))))
+
+(test-end "build-emacs-utils")