aboutsummaryrefslogtreecommitdiff
path: root/tests/base16.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-15 21:54:34 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-16 22:50:14 +0100
commit4c0c4db0702048488a9712dbba7cad862c667d54 (patch)
tree5c809914cc75d5fc7a386f382db40253d71e959c /tests/base16.scm
parent2c715a922324e0cd1ab50c5ea0b70f12a33565d5 (diff)
downloadguix-4c0c4db0702048488a9712dbba7cad862c667d54.tar
guix-4c0c4db0702048488a9712dbba7cad862c667d54.tar.gz
utils: Move base16 procedures to (guix base16).
* guix/utils.scm (bytevector->base16-string, base16-string->bytevector): Move to... * guix/base16.scm: ... here. New file. * tests/utils.scm ("bytevector->base16-string->bytevector"): Move to... * tests/base16.scm: ... here. New file. * Makefile.am (MODULES): Add guix/base16.scm. (SCM_TESTS): Add tests/base16.scm. * build-aux/download.scm, guix/derivations.scm, guix/docker.scm, guix/import/snix.scm, guix/pk-crypto.scm, guix/scripts/authenticate.scm, guix/scripts/download.scm, guix/scripts/hash.scm, guix/store.scm, tests/hash.scm, tests/pk-crypto.scm: Adjust imports accordingly.
Diffstat (limited to 'tests/base16.scm')
-rw-r--r--tests/base16.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/base16.scm b/tests/base16.scm
new file mode 100644
index 0000000000..a64b650bec
--- /dev/null
+++ b/tests/base16.scm
@@ -0,0 +1,34 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012, 2017 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-base16)
+ #:use-module (guix base16)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-64)
+ #:use-module (rnrs bytevectors))
+
+(test-begin "base16")
+
+(test-assert "bytevector->base16-string->bytevector"
+ (every (lambda (bv)
+ (equal? (base16-string->bytevector
+ (bytevector->base16-string bv))
+ bv))
+ (map string->utf8 '("" "f" "fo" "foo" "foob" "fooba" "foobar"))))
+
+(test-end "base16")