aboutsummaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-12-05 12:59:15 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2017-12-15 11:52:38 +0100
commite22482038611a53a9d2b25df20363664cd91be2e (patch)
treeda53181cdbbe40b8035fdc577b0767e8055c9681 /guix
parentacf54bca225b63f5b06e335a55045421c47bbd09 (diff)
downloadguix-e22482038611a53a9d2b25df20363664cd91be2e.tar
guix-e22482038611a53a9d2b25df20363664cd91be2e.tar.gz
bootloader: Factorize write-file-on-device.
* gnu/bootloader/extlinux.scm (install-extlinux): Factorize bootloader writing in a new procedure write-file-on-device defined in (gnu build bootloader). * gnu/build/bootloader.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new file. * gnu/system/vm.scm (qemu-img): Adapt to import and use (gnu build bootloader) module during derivation building. * gnu/scripts/system.scm (bootloader-installer-derivation): Ditto.
Diffstat (limited to 'guix')
-rw-r--r--guix/scripts/system.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/guix/scripts/system.scm b/guix/scripts/system.scm
index d0eacc573c..cbf7e6cd03 100644
--- a/guix/scripts/system.scm
+++ b/guix/scripts/system.scm
@@ -674,9 +674,11 @@ any, are available. Raise an error if they're not."
and TARGET arguments."
(with-monad %store-monad
(gexp->file "bootloader-installer"
- (with-imported-modules '((guix build utils))
+ (with-imported-modules '((gnu build bootloader)
+ (guix build utils))
#~(begin
- (use-modules (guix build utils)
+ (use-modules (gnu build bootloader)
+ (guix build utils)
(ice-9 binary-ports))
(#$installer #$bootloader #$device #$target))))))