aboutsummaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2024-02-29 16:20:44 +0100
committerLudovic Courtès <ludo@gnu.org>2024-04-17 12:13:02 +0200
commit9a60894156c3ea2c609ae0cd787df949f2d6ecc2 (patch)
tree858792c3e7f7c9bd65346226396211a8b2ef94bc /guix
parent9d5356dbc33009ad4ac879325a8dc3393e600591 (diff)
downloadguix-9a60894156c3ea2c609ae0cd787df949f2d6ecc2.tar
guix-9a60894156c3ea2c609ae0cd787df949f2d6ecc2.tar.gz
guix: Add xtensa-ath9k-elf platform.
* Makefile.am (MODULES): Add guix/platforms/xtensa.scm. * guix/platforms/xtensa.scm (xtensa-ath9k-elf): New variable. * doc/guix.texi: Add xtensa-ath9k-elf documentation. Change-Id: I51eef245142ed58613340c16d4bf7266e6bf6adb Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix')
-rw-r--r--guix/platforms/xtensa.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/guix/platforms/xtensa.scm b/guix/platforms/xtensa.scm
new file mode 100644
index 0000000000..304e23ab1a
--- /dev/null
+++ b/guix/platforms/xtensa.scm
@@ -0,0 +1,28 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix platforms xtensa)
+ #:use-module (guix platform)
+ #:use-module (guix records)
+ #:export (xtensa-ath9k-elf))
+
+(define xtensa-ath9k-elf
+ (platform
+ (target "xtensa-ath9k-elf")
+ (system #f)
+ (glibc-dynamic-linker #f)))