aboutsummaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-25 10:34:27 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-25 10:46:22 +0100
commit2c74fde00e4e721c6a73646935ab0cfe19dd9188 (patch)
treeec1660e4c859c0232d94ff0048bde63a80978d03 /guix
parentc3a450fb49da41f1225353d2ca2e652daae36939 (diff)
downloadguix-2c74fde00e4e721c6a73646935ab0cfe19dd9188.tar
guix-2c74fde00e4e721c6a73646935ab0cfe19dd9188.tar.gz
Rename 'guix substitute-binary' to 'guix substitute'.
* guix/scripts/substitute-binary.scm: Rename to... * guix/scripts/substitute.scm: ... this. Adjust module name, entry point, comments, and help string accordingly. * nix/scripts/substitute-binary.in: Rename to... * nix/scripts/substitute.in: ... this. * pre-inst-env.in (NIX_SUBSTITUTERS): Adjust accordingly. * tests/substitute-binary.scm: Rename to... * tests/substitute.scm: ... this. Adjust references to (guix scripts substitute) accordingly. * guix/ui.scm (show-guix-help)[internal?]: Change "substitute-binary" to "substitute". * Makefile.am (MODULES, SCM_TESTS): Adjust to file renames. * daemon.am (nodist_pkglibexec_SCRIPTS): Likewise. * config-daemon.ac: Likewise. * guix/tests.scm (call-with-derivation-narinfo): Adjust comments and docstring.
Diffstat (limited to 'guix')
-rwxr-xr-xguix/scripts/substitute.scm (renamed from guix/scripts/substitute-binary.scm)12
-rw-r--r--guix/tests.scm4
-rw-r--r--guix/ui.scm2
3 files changed, 9 insertions, 9 deletions
diff --git a/guix/scripts/substitute-binary.scm b/guix/scripts/substitute.scm
index e797c6d40b..e99c29945c 100755
--- a/guix/scripts/substitute-binary.scm
+++ b/guix/scripts/substitute.scm
@@ -17,7 +17,7 @@
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-(define-module (guix scripts substitute-binary)
+(define-module (guix scripts substitute)
#:use-module (guix ui)
#:use-module (guix store)
#:use-module (guix utils)
@@ -53,7 +53,7 @@
#:export (narinfo-signature->canonical-sexp
read-narinfo
write-narinfo
- guix-substitute-binary))
+ guix-substitute))
;;; Comment:
;;;
@@ -675,7 +675,7 @@ PORT. REPORT-PROGRESS is a two-argument procedure such as that returned by
;;;
(define (show-help)
- (display (_ "Usage: guix substitute-binary [OPTION]...
+ (display (_ "Usage: guix substitute [OPTION]...
Internal tool to substitute a pre-built binary to a local build.\n"))
(display (_ "
--query report on the availability of substitutes for the
@@ -761,7 +761,7 @@ found."
;; daemon.
"http://hydra.gnu.org")))
-(define (guix-substitute-binary . args)
+(define (guix-substitute . args)
"Implement the build daemon's substituter protocol."
(mkdir-p %narinfo-cache-directory)
(maybe-remove-expired-cached-narinfo)
@@ -882,7 +882,7 @@ substituter disabled~%")
(every (compose zero? cdr waitpid) pids))))
(("--version")
- (show-version-and-exit "guix substitute-binary"))
+ (show-version-and-exit "guix substitute"))
(("--help")
(show-help))
(opts
@@ -893,4 +893,4 @@ substituter disabled~%")
;;; eval: (put 'with-timeout 'scheme-indent-function 1)
;;; End:
-;;; substitute-binary.scm ends here
+;;; substitute.scm ends here
diff --git a/guix/tests.scm b/guix/tests.scm
index 0896e842da..080ee9cc74 100644
--- a/guix/tests.scm
+++ b/guix/tests.scm
@@ -126,7 +126,7 @@ Deriver: ~a~%"
(define* (call-with-derivation-narinfo drv thunk
#:key (sha256 (make-bytevector 32 0)))
"Call THUNK in a context where fake substituter data, as read by 'guix
-substitute-binary', has been installed for DRV. SHA256 is the hash of the
+substitute', has been installed for DRV. SHA256 is the hash of the
expected output of DRV."
(let* ((output (derivation->output-path drv))
(dir (%substitute-directory))
@@ -178,7 +178,7 @@ CONTENTS."
(lambda ()
(let ((hash (call-with-input-file (string-append dir "/example.nar")
port-sha256)))
- ;; Create fake substituter data, to be read by `substitute-binary'.
+ ;; Create fake substituter data, to be read by 'guix substitute'.
(call-with-derivation-narinfo drv
thunk
#:sha256 (or sha256 hash))))
diff --git a/guix/ui.scm b/guix/ui.scm
index ae37c8e6ca..4929f93590 100644
--- a/guix/ui.scm
+++ b/guix/ui.scm
@@ -815,7 +815,7 @@ parameter of 'args-fold'."
(define (show-guix-help)
(define (internal? command)
- (member command '("substitute-binary" "authenticate" "offload")))
+ (member command '("substitute" "authenticate" "offload")))
(format #t (_ "Usage: guix COMMAND ARGS...
Run COMMAND with ARGS.\n"))