aboutsummaryrefslogtreecommitdiff
path: root/guix/utils.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-17 13:51:05 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-17 14:38:32 +0200
commitff690faf66d8f37ee6b679fcb7cf37e369624ee3 (patch)
tree3d6ab4ebded5a48f349ca5701643699e178481b4 /guix/utils.scm
parent52f2980fa3feaf6e59b9e5144391faf8feb52a87 (diff)
downloadguix-ff690faf66d8f37ee6b679fcb7cf37e369624ee3.tar
guix-ff690faf66d8f37ee6b679fcb7cf37e369624ee3.tar.gz
gnu: Use target-hurd?, system-hurd? instead of hurd-target?, hurd-system?.
* gnu/packages/hurd.scm (hurd-target?): Remove. (hurd-system?): Move to... * guix/utils.scm (system-hurd?): ...here. * gnu/packages/*: Update all users, removing (gnu packages hurd) include where now unused.
Diffstat (limited to 'guix/utils.scm')
-rw-r--r--guix/utils.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/guix/utils.scm b/guix/utils.scm
index b9657df292..e9af33bdeb 100644
--- a/guix/utils.scm
+++ b/guix/utils.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2023 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -89,6 +90,7 @@
package-name->name+version
target-linux?
target-hurd?
+ system-hurd?
target-mingw?
target-x86-32?
target-x86-64?
@@ -674,6 +676,10 @@ a character other than '@'."
(and (string-suffix? "-gnu" target)
(not (string-contains target "linux"))))
+(define* (system-hurd?)
+ "Is the current system the GNU(/Hurd) system?"
+ (and=> (%current-system) target-hurd?))
+
(define* (target-mingw? #:optional (target (%current-target-system)))
"Is the operating system of TARGET Windows?"
(and target