aboutsummaryrefslogtreecommitdiff
path: root/guix/self.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-08-22 23:46:05 +0200
committerLudovic Courtès <ludo@gnu.org>2023-08-22 23:50:53 +0200
commitf4d0d0bd5e7d0e67281d84d81068f7fd5eb480ea (patch)
tree896dbec8c72c8271133a7c7b41cb7c42d692a4c0 /guix/self.scm
parentdb02fcde386892b3a054d64403a4a5bfa1b7fce8 (diff)
downloadguix-f4d0d0bd5e7d0e67281d84d81068f7fd5eb480ea.tar
guix-f4d0d0bd5e7d0e67281d84d81068f7fd5eb480ea.tar.gz
Revert "self: Build gnu/packages/*.go in 26 steps."
This reverts commit 5898b2e8a3dbf7797e83b39a2783c5b543015725, which led to Guix where many .go files would be missing, as reported in <https://issues.guix.gnu.org/65456>.
Diffstat (limited to 'guix/self.scm')
-rw-r--r--guix/self.scm33
1 files changed, 7 insertions, 26 deletions
diff --git a/guix/self.scm b/guix/self.scm
index 239727dfa8..81a36e007f 100644
--- a/guix/self.scm
+++ b/guix/self.scm
@@ -1,7 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
-;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1211,12 +1210,9 @@ containing MODULE-FILES and possibly other files as well."
'((guix build compile)
(guix build utils)))
#~(begin
- (use-modules (srfi srfi-1)
- (srfi srfi-26)
- (srfi srfi-71)
+ (use-modules (srfi srfi-26)
(ice-9 match)
(ice-9 format)
- (ice-9 regex)
(ice-9 threads)
(guix build compile)
(guix build utils))
@@ -1248,27 +1244,12 @@ containing MODULE-FILES and possibly other files as well."
(force-output))
(define (process-directory directory files output)
- ;; Split gnu/packages in 26 chunks to avoid OOM errors
- (let* ((chunks (map (compose
- (cute partition <> files)
- (lambda (regex)
- (cute string-match regex <>))
- (cute string-append "^gnu/packages/" <>)
- (cute make-string 1 <>)
- integer->char
- (cute + (char->integer #\a) <>))
- (iota 26)))
- (chunks (filter pair? chunks)))
- (for-each
- (lambda (chunck)
- ;; Hide compilation warnings.
- (parameterize ((current-warning-port (%make-void-port "w")))
- (compile-files directory #$output chunck
- #:workers (parallel-job-count)
- #:report-load report-load
- #:report-compilation report-compilation))
- (gc))
- chunks)))
+ ;; Hide compilation warnings.
+ (parameterize ((current-warning-port (%make-void-port "w")))
+ (compile-files directory #$output files
+ #:workers (parallel-job-count)
+ #:report-load report-load
+ #:report-compilation report-compilation)))
(setvbuf (current-output-port) 'line)
(setvbuf (current-error-port) 'line)