aboutsummaryrefslogtreecommitdiff
path: root/guix/search-paths.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-24 17:30:03 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-06 21:27:06 -0500
commitff5f34ae757d709987896d6164bf125319a0f764 (patch)
treef62812e8ff2a7ad75f84aab22c21f7c4bf057bdb /guix/search-paths.scm
parentaca64d560452812208c654abba1ec3ab7041eefd (diff)
downloadguix-ff5f34ae757d709987896d6164bf125319a0f764.tar
guix-ff5f34ae757d709987896d6164bf125319a0f764.tar.gz
gnu: perl-extutils-pkgconfig: Support cross-compilation.
* guix/search-paths.scm ($PKG_CONFIG_PATH): New variable. * gnu/packages/pkg-config.scm (%pkg-config): Use it. * gnu/packages/perl.scm (perl-extutils-pkgconfig-for-target): New procedure. (perl-extutils-pkgconfig): Turn into a syntax that conditionally expands to... (cross-perl-extutils-pkgconfig): ... this when %current-target-system is set, or... (%perl-extutils-pkgconfig): ... this in a native compilation context. [arguments]: New field. [propagated-inputs]: Turn into... [native-inputs]: ... this. [native-search-paths]: New field.
Diffstat (limited to 'guix/search-paths.scm')
-rw-r--r--guix/search-paths.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/guix/search-paths.scm b/guix/search-paths.scm
index 4a8f5131ed..fcbe7b7953 100644
--- a/guix/search-paths.scm
+++ b/guix/search-paths.scm
@@ -34,6 +34,7 @@
$PATH
$GUIX_EXTENSIONS_PATH
+ $PKG_CONFIG_PATH
$SSL_CERT_DIR
$SSL_CERT_FILE
@@ -83,6 +84,13 @@
(variable "GUIX_EXTENSIONS_PATH")
(files '("share/guix/extensions"))))
+(define $PKG_CONFIG_PATH
+ ;; 'PKG_CONFIG_PATH' is used by pkg-config to locate available header files
+ ;; and libraries, via their .pc files.
+ (search-path-specification
+ (variable "PKG_CONFIG_PATH")
+ (files '("lib/pkgconfig" "lib64/pkgconfig" "share/pkgconfig"))))
+
;; Two variables for certificates (info "(guix)X.509 Certificates"),
;; respected by OpenSSL and possibly GnuTLS in the future
;; (https://gitlab.com/gnutls/gnutls/-/merge_requests/1541)