aboutsummaryrefslogtreecommitdiff
path: root/guix/profiles.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 12:22:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:08 +0200
commit3f8b75b35ca553c46cde34736f57b52aad02af72 (patch)
treee9028ee0896f30138dfb39b550803abe805891d2 /guix/profiles.scm
parent19fd1004138b60c4479d7516aa0cee261c0b6b57 (diff)
downloadguix-3f8b75b35ca553c46cde34736f57b52aad02af72.tar
guix-3f8b75b35ca553c46cde34736f57b52aad02af72.tar.gz
gnu: Remove texlive-default-updmap.cfg.
* gnu/packages/tex.scm (texlive-scripts): Provide "updmap.cfg", along with other similar files. (texlive-default-updmap.cfg): Remove variable. (texlive-updmap.cfg)[source]: Use TEXLIVE-SCRIPTS source. [arguments]: Use G-expressions. Adapt #:INSTALL-PLAN according to source change. * guix/profiles.scm (texlive-font-maps): Use "updmap.cfg" provided by TEXLIVE-SCRIPTS instead of now defunct TEXLIVE-DEFAULT-UPDMAP.CFG.
Diffstat (limited to 'guix/profiles.scm')
-rw-r--r--guix/profiles.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/guix/profiles.scm b/guix/profiles.scm
index 75ce2b4d08..d0006dc2bf 100644
--- a/guix/profiles.scm
+++ b/guix/profiles.scm
@@ -1799,9 +1799,6 @@ MANIFEST."
(module-ref (resolve-interface '(gnu packages base)) 'grep))
(define sed
(module-ref (resolve-interface '(gnu packages base)) 'sed))
- (define updmap.cfg
- (module-ref (resolve-interface '(gnu packages tex))
- 'texlive-default-updmap.cfg))
(define build
(with-imported-modules '((guix build utils)
(guix build union))
@@ -1835,7 +1832,9 @@ MANIFEST."
(let* ((web2c (string-append #$output "/share/texmf-dist/web2c/"))
(maproot (string-append #$output "/share/texmf-dist/fonts/map/"))
(updmap.cfg (string-append web2c "updmap.cfg")))
- (install-file #$(file-append updmap.cfg "/web2c/updmap.cfg") web2c)
+ (install-file #$(file-append texlive-scripts
+ "/share/texmf-dist/web2c/updmap.cfg")
+ web2c)
(make-file-writable updmap.cfg)
(let* ((port (open-pipe* OPEN_WRITE
#$(file-append texlive-scripts "/bin/updmap-sys")
@@ -1867,6 +1866,8 @@ MANIFEST."
(let ((a (string-append #$output "/share/texmf-dist"))
(b "/tmp/texlive/share/texmf-dist")
(mktexlsr #$(file-append texlive-scripts "/bin/mktexlsr")))
+ ;; Ignore original "updmap.cfg" from texlive-scripts input.
+ (delete-file "/tmp/texlive/share/texmf-dist/web2c/updmap.cfg")
(copy-recursively a b)
(invoke mktexlsr b)
(install-file (string-append b "/ls-R") a))))))