aboutsummaryrefslogtreecommitdiff
path: root/guix/platforms
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-05-25 17:04:51 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-05-25 17:11:32 +0200
commitd2c06bf2ff424c6076b3e847119a3952f7a6ce40 (patch)
tree2a39fa8aa1a75d20a68f5f128dc64e39e3f7dfa5 /guix/platforms
parente0e1bf440937b3f68d29839fb7c5d70061a3129d (diff)
downloadguix-d2c06bf2ff424c6076b3e847119a3952f7a6ce40.tar
guix-d2c06bf2ff424c6076b3e847119a3952f7a6ce40.tar.gz
platforms: Remove the s390x platform.
Turns out this platform doesn't have a bootstrap tarball and should be considered as not supported for now. * guix/platforms/s390.scm: Remove it. * Makefile.am (MODULES): Adapt it. * doc/guix.texi (Foreign Architectures): Ditto.
Diffstat (limited to 'guix/platforms')
-rw-r--r--guix/platforms/s390.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/guix/platforms/s390.scm b/guix/platforms/s390.scm
deleted file mode 100644
index b5477f1e5e..0000000000
--- a/guix/platforms/s390.scm
+++ /dev/null
@@ -1,29 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (guix platforms s390)
- #:use-module (guix platform)
- #:use-module (guix records)
- #:export (s390x-linux))
-
-(define s390x-linux
- (platform
- (target "s390x-linux-gnu")
- (system "s390x-linux")
- (linux-architecture "s390")
- (glibc-dynamic-linker "/lib/ld64.so.1")))