aboutsummaryrefslogtreecommitdiff
path: root/guix/platforms
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-05-25 13:01:15 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-05-25 13:01:15 +0200
commita9dcd60bc11afb3934c11fbad159a16f0f223fd1 (patch)
treeeb50c53a1f61d76c39e5387892823a648e94b573 /guix/platforms
parentd18673dbf2deb105d10667362a18dd8fb1cecc80 (diff)
downloadguix-a9dcd60bc11afb3934c11fbad159a16f0f223fd1.tar
guix-a9dcd60bc11afb3934c11fbad159a16f0f223fd1.tar.gz
platforms: Remove the hurd module.
The hurd platform is now defined in the (guix platforms x86) module. * guix/platforms/hurd.scm: Remove it. * Makefile.am (MODULES): Adapt it.
Diffstat (limited to 'guix/platforms')
-rw-r--r--guix/platforms/hurd.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/guix/platforms/hurd.scm b/guix/platforms/hurd.scm
deleted file mode 100644
index baa6c23b41..0000000000
--- a/guix/platforms/hurd.scm
+++ /dev/null
@@ -1,28 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (guix platforms hurd)
- #:use-module (guix platform)
- #:use-module (guix records)
- #:export (hurd))
-
-(define hurd
- (platform
- (target "i586-pc-gnu")
- (system "i586-gnu")
- (glibc-dynamic-linker "/lib/ld.so.1")))