aboutsummaryrefslogtreecommitdiff
path: root/guix/packages.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-09 09:15:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-05-23 22:23:18 +0300
commitcbdb7d4fea928febc105985c03b8fb5d6eda3d27 (patch)
treeb054204c835b074a0b62ccf82a2cd2eba3ac058c /guix/packages.scm
parent0de7945dc47612286ef080315a5a78f019b161b6 (diff)
downloadguix-cbdb7d4fea928febc105985c03b8fb5d6eda3d27.tar
guix-cbdb7d4fea928febc105985c03b8fb5d6eda3d27.tar.gz
gnu: bootstrap: Add support for powerpc-linux.
On 923bb70a1bff657125c3008f119a477e5cb57c2b gnu:glibc-for-bootstrap: Fix patch. Run ./pre-inst-env guix build --target=powerpc-linux-gnu bootstrap-tarballs Producing /gnu/store/dyj1wvayyp1ihaknkxniz1xamcf4yrhl-bootstrap-tarballs-0 With guix hash -rx /gnu/store/dyj1wvayyp1ihaknkxniz1xamcf4yrhl-bootstrap-tarballs-0 02xx2ydj28pwv3vflqffinpq1icj09gzi9icm8j4bwc4lca9irxn * gnu/packages/bootstrap.scm (%bootstrap-executables): Add entries for powerpc-linux. (%bootstrap-guile-hash, %bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc, %bootstrap-gcc): Add entry for powerpc-linux. * gnu/packages.scm (%supported-systems): Add powerpc-linux. (%hydra-supported-systems): Remove powerpc-linux. * m4/guix.m4: Add powerpc-linux as a supported system.
Diffstat (limited to 'guix/packages.scm')
-rw-r--r--guix/packages.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/packages.scm b/guix/packages.scm
index ba19174646..a66dbea1b7 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -353,7 +353,7 @@ name of its URI."
;; This is the list of system types that are supported. By default, we
;; expect all packages to build successfully here.
'("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "mips64el-linux" "i586-gnu"
- "powerpc64le-linux"))
+ "powerpc64le-linux" "powerpc-linux"))
(define %hurd-systems
;; The GNU/Hurd systems for which support is being developed.
@@ -364,7 +364,7 @@ name of its URI."
;;
;; XXX: MIPS is unavailable in CI:
;; <https://lists.gnu.org/archive/html/guix-devel/2017-03/msg00790.html>.
- (fold delete %supported-systems '("mips64el-linux")))
+ (fold delete %supported-systems '("mips64el-linux" "powerpc-linux")))
;; A package.