aboutsummaryrefslogtreecommitdiff
path: root/guix/narinfo.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-22 22:42:03 +0000
committerChristopher Baines <mail@cbaines.net>2021-03-05 21:06:03 +0000
commit112692c0d546d35cd67c5dc70dbd1dc609b18f64 (patch)
treee4de94ece7e22009e57e52ee58a21619df256381 /guix/narinfo.scm
parent23c6be1d3dfb4c6fa6170d7fff348e82f379a0ba (diff)
downloadguix-112692c0d546d35cd67c5dc70dbd1dc609b18f64.tar
guix-112692c0d546d35cd67c5dc70dbd1dc609b18f64.tar.gz
guix: Split (guix substitutes) from (guix scripts substitute).
This means there's a module for working with substitutes, rather than all the code sitting in the script. The need for this can be seen with the weather and challenge scripts, that now don't have to use code from the substitute script, but can instead use the substitute module. The separation here between the actual functionality of the substitute script and the underlying functionality used both there and elsewhere should make maintenance easier moving forward. This commit just moves code, none of the code should have been changed significantly. * guix/scripts/substitute.scm (%narinfo-cache-directory, %narinfo-ttl, %narinfo-negative-ttl, %narinfo-transient-error-ttl, %unreachable-hosts): Move variables to guix/substitutes.scm. (narinfo-cache-file, cached-narinfo, cache-narinfo!, narinfo-request, read-to-eof, call-with-connection-error-handling, fetch-narinfos, lookup-narinfos, lookup-narinfos/diverse): Move procedures to guix/substitutes.scm. * guix/substitutes.scm: New file. * Makefile.am: Add it. * guix/narinfo.scm: Remove redundant module. * guix/scripts/challenge.scm: Change (guix scripts substitute) to (guix substitutes). * guix/scripts/weather.scm: Change (guix scripts substitute) to (guix substitutes).
Diffstat (limited to 'guix/narinfo.scm')
-rw-r--r--guix/narinfo.scm1
1 files changed, 0 insertions, 1 deletions
diff --git a/guix/narinfo.scm b/guix/narinfo.scm
index d3deba28bd..2d06124017 100644
--- a/guix/narinfo.scm
+++ b/guix/narinfo.scm
@@ -25,7 +25,6 @@
#:use-module (guix base64)
#:use-module (guix records)
#:use-module (guix diagnostics)
- #:use-module (guix scripts substitute)
#:use-module (gcrypt hash)
#:use-module (gcrypt pk-crypto)
#:use-module (rnrs bytevectors)