aboutsummaryrefslogtreecommitdiff
path: root/guix/lint.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 21:18:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:50 -0400
commitcc7a79a8ade673cc66249c7b4583a0074348b370 (patch)
tree5acd0036692ba001bb132e4e76e438f9d3cf15cd /guix/lint.scm
parentd2aa65fc672aace78ab5541b9e05694a956ca283 (diff)
downloadguix-cc7a79a8ade673cc66249c7b4583a0074348b370.tar
guix-cc7a79a8ade673cc66249c7b4583a0074348b370.tar.gz
Revert "lint: Append "/info/refs" to git-reference-url."
This reverts commit c9af27d4ca733b20f09019f1465d3e5fdc1ec724. The change causes 'guix lint' to print URI not reachable (403) errors for GitHub every URLs.
Diffstat (limited to 'guix/lint.scm')
-rw-r--r--guix/lint.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/guix/lint.scm b/guix/lint.scm
index 3a93ba5325..9eece374ff 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -1224,14 +1224,7 @@ password, provided REF's URI is HTTP or HTTPS."
'())))
((git-reference? (origin-uri origin))
(warnings-for-uris
- ;; for atftp, lint produced a warning:
- ;; gnu/packages/networking.scm:2924:5: atftp@0.8.0:
- ;; URI https://git.code.sf.net/p/atftp/code not reachable:
- ;; 404 ("Not Found")
- ;; fix from here: https://issues.guix.gnu.org/62156#3
- (list (string->uri (string-append
- (git-reference-url (origin-uri origin))
- "/info/refs")))))
+ (list (string->uri (git-reference-url (origin-uri origin))))))
((or (svn-reference? (origin-uri origin))
(svn-multi-reference? (origin-uri origin)))
(let ((uri (svn-reference-uri-with-userinfo (origin-uri origin))))