aboutsummaryrefslogtreecommitdiff
path: root/guix/describe.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-09-03 15:03:33 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-07 11:40:22 +0200
commitbd7470185bae15e686c2b2a83d3f61807e6fa527 (patch)
treee0e42c0a5c9be1993dea5622d5e6bb7464d1f757 /guix/describe.scm
parentee94cfeb99a7e3879c92ca21318960077ce4100e (diff)
downloadguix-bd7470185bae15e686c2b2a83d3f61807e6fa527.tar
guix-bd7470185bae15e686c2b2a83d3f61807e6fa527.tar.gz
Add 'guix describe'.
* guix/scripts/describe.scm: New file. * Makefile.am (MODULES): Add it. (SH_TESTS): Add tests/guix-describe.sh. * po/guix/POTFILES.in: Add it. * guix/scripts/pull.scm (display-profile-content): Export. * guix/describe.scm (current-profile, current-profile-entries): Export. * tests/guix-describe.sh: New file. * doc/guix.texi (Features): Mention 'guix pull' and provenance tracking. (Invoking guix pull): Link to 'guix describe'. (Channels): Likewise. (Invoking guix describe): New node.
Diffstat (limited to 'guix/describe.scm')
-rw-r--r--guix/describe.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/guix/describe.scm b/guix/describe.scm
index 3122a762fe..670db63ce7 100644
--- a/guix/describe.scm
+++ b/guix/describe.scm
@@ -21,7 +21,9 @@
#:use-module (guix profiles)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match)
- #:export (package-path-entries))
+ #:export (current-profile
+ current-profile-entries
+ package-path-entries))
;;; Commentary:
;;;