aboutsummaryrefslogtreecommitdiff
path: root/guix/build/utils.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2020-09-13 15:45:54 +1000
committerLudovic Courtès <ludo@gnu.org>2021-04-22 14:04:27 +0200
commitb2b799e2d8330af934f48bf66afb5114addb4dd7 (patch)
tree8863ff1aa826ed98fcf237ff1279a6f6c445705a /guix/build/utils.scm
parentd11574736207c69e40a5ee422e7b0465629a37cd (diff)
downloadguix-b2b799e2d8330af934f48bf66afb5114addb4dd7.tar
guix-b2b799e2d8330af934f48bf66afb5114addb4dd7.tar.gz
utils: Rename 'wrapper?' to 'wrapped-program?'.
* guix/build/utils.scm (wrap-program): The wrapper? procedure is incorrectly named as it actually checks to see if prog is the original program that was moved, not the wrapper. * guix/build/python-build-system: (wrap): Use renamed wrapped-program?. * gnu/packages/ebook.scm (calibre)[arguments]: Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/build/utils.scm')
-rw-r--r--guix/build/utils.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/guix/build/utils.scm b/guix/build/utils.scm
index 6c37021673..a15beac114 100644
--- a/guix/build/utils.scm
+++ b/guix/build/utils.scm
@@ -96,7 +96,7 @@
patch-/usr/bin/file
fold-port-matches
remove-store-references
- wrapper?
+ wrapped-program?
wrap-program
wrap-script
@@ -1227,8 +1227,8 @@ known as `nuke-refs' in Nixpkgs."
(program wrap-error-program)
(type wrap-error-type))
-(define (wrapper? prog)
- "Return #t if PROG is a wrapper as produced by 'wrap-program'."
+(define (wrapped-program? prog)
+ "Return #t if PROG is a program that was moved and wrapped by 'wrap-program'."
(and (file-exists? prog)
(let ((base (basename prog)))
(and (string-prefix? "." base)