aboutsummaryrefslogtreecommitdiff
path: root/guix/build/make-bootstrap.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2017-02-25 18:57:14 +0200
committerManolis Ragkousis <manolis837@gmail.com>2017-02-27 15:31:06 +0200
commit751702676e0dcf39657082138f45340b65ae4d3e (patch)
tree28a1e75724f855ed8798cea8c5c9ab5dc078d9f6 /guix/build/make-bootstrap.scm
parent8e5652f924a5ef8605b791999b600fd510a8f6e6 (diff)
downloadguix-751702676e0dcf39657082138f45340b65ae4d3e.tar
guix-751702676e0dcf39657082138f45340b65ae4d3e.tar.gz
guix: build: make-bootstrap: Copy "falloc.h" to the new system.
In glibc-2.25 a dependency on "linux/falloc.h" was added. This also reverts commit 8f8f250bdca917b3ce38aa0902f01b19081859a4 which is no longer needed. This commit was not compatible with the glibc version Hurd is using. See <https://lists.gnu.org/archive/html/guix-devel/2017-02/msg01046.html> * guix/build/make-bootstrap.scm (make-stripped-libc): Copy "falloc.h" to the new system. * gnu/packages/patches/glibc-bootstrap-system.patch: Remove part that touches fcntl-linux.h. Problem reported by Andreas Enge <andreas@enge.fr>.
Diffstat (limited to 'guix/build/make-bootstrap.scm')
-rw-r--r--guix/build/make-bootstrap.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build/make-bootstrap.scm b/guix/build/make-bootstrap.scm
index 21c78cc8f5..43b136248f 100644
--- a/guix/build/make-bootstrap.scm
+++ b/guix/build/make-bootstrap.scm
@@ -55,7 +55,7 @@ when producing a bootstrap libc."
(string-append incdir "/linux")))
'("limits.h" "errno.h" "socket.h" "kernel.h"
"sysctl.h" "param.h" "ioctl.h" "types.h"
- "posix_types.h" "stddef.h"))
+ "posix_types.h" "stddef.h" "falloc.h"))
(copy-recursively (string-append kernel-headers "/include/asm")
(string-append incdir "/asm"))