aboutsummaryrefslogtreecommitdiff
path: root/guix/build/java-utils.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-09 16:51:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-10 17:59:22 +0200
commit59135f0d7e52657bff8bc9f8b0a9133ee671f777 (patch)
tree5464580f87123b73ca5d75ab7d4e0f561da22352 /guix/build/java-utils.scm
parent52a791f50ffe460e2985dc356f08789d2d6f9f12 (diff)
downloadguix-59135f0d7e52657bff8bc9f8b0a9133ee671f777.tar
guix-59135f0d7e52657bff8bc9f8b0a9133ee671f777.tar.gz
guix: Add java-utils.
* guix/build/java-utils.scm: New file. * guix/build-system/ant.scm: Use it. * Makefile.am (MODULES): Add it. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'guix/build/java-utils.scm')
-rw-r--r--guix/build/java-utils.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/guix/build/java-utils.scm b/guix/build/java-utils.scm
new file mode 100644
index 0000000000..402d377bf8
--- /dev/null
+++ b/guix/build/java-utils.scm
@@ -0,0 +1,55 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build java-utils)
+ #:use-module (guix build utils)
+ #:export (ant-build-javadoc
+ install-jars
+ install-javadoc))
+
+;; Copied from haskell-build-system.scm
+(define (package-name-version store-dir)
+ "Given a store directory STORE-DIR return 'name-version' of the package."
+ (let* ((base (basename store-dir)))
+ (string-drop base (+ 1 (string-index base #\-)))))
+
+(define* (ant-build-javadoc #:key (target "javadoc") (make-flags '())
+ #:allow-other-keys)
+ (zero? (apply system* `("ant" ,target ,@make-flags))))
+
+(define* (install-jars jar-directory)
+ "Install jar files from JAR-DIRECTORY to the default target directory. This
+is used in case the build.xml does not include an install target."
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((share (string-append (assoc-ref outputs "out")
+ "/share/java")))
+ (for-each (lambda (f) (install-file f share))
+ (find-files jar-directory "\\.jar$"))
+ #t)))
+
+(define* (install-javadoc apidoc-directory)
+ "Install the APIDOC-DIRECTORY to the target directory. This is used to
+install javadocs when this is not done by the install target."
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (docs (string-append (or (assoc-ref outputs "doc") out)
+ "/share/doc/" (package-name-version out) "/")))
+ (mkdir-p docs)
+ (copy-recursively apidoc-directory docs)
+ #t)))