aboutsummaryrefslogtreecommitdiff
path: root/guix/build/go-build-system.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-07-25 12:51:13 -0400
committerLeo Famulari <leo@famulari.name>2019-07-29 14:57:07 -0400
commit0c3c597d2ed649005798f670b13755ee55e6dc9a (patch)
treeec70ad328a08ed695a1d54d306e7d8ab3a5aeecd /guix/build/go-build-system.scm
parent20470893ea8919f59384bd1c68df7f968d8c0f57 (diff)
downloadguix-0c3c597d2ed649005798f670b13755ee55e6dc9a.tar
guix-0c3c597d2ed649005798f670b13755ee55e6dc9a.tar.gz
gnu: Update default Go compiler to Go 1.12.
* gnu/packages/golang.scm (go): Update to go-1.12. * guix/build/go-build-system.scm (setup-go-environment): Set $GOCACHE.
Diffstat (limited to 'guix/build/go-build-system.scm')
-rw-r--r--guix/build/go-build-system.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/guix/build/go-build-system.scm b/guix/build/go-build-system.scm
index 858068ba98..3dac43c18a 100644
--- a/guix/build/go-build-system.scm
+++ b/guix/build/go-build-system.scm
@@ -135,6 +135,9 @@ of the package being built and its dependencies, and GOBIN, which determines
where executables (\"commands\") are installed to. This phase is sometimes used
by packages that use (guix build-system gnu) but have a handful of Go
dependencies, so it should be self-contained."
+ ;; The Go cache is required starting in Go 1.12. We don't actually use it but
+ ;; we need it to be a writable directory.
+ (setenv "GOCACHE" "/tmp/go-cache")
;; Using the current working directory as GOPATH makes it easier for packagers
;; who need to manipulate the unpacked source code.
(setenv "GOPATH" (getcwd))