aboutsummaryrefslogtreecommitdiff
path: root/guix/build/bzr.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-11-20 23:11:29 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-09 00:22:37 -0400
commit4ac69ea10f54384ac893313ef738e5ad554ac328 (patch)
treedcbe1033a84ac70b0422b42cb4ef6ba1d4aa4120 /guix/build/bzr.scm
parentc526b3176fb85175ea0d3a5b561927a23522263b (diff)
downloadguix-4ac69ea10f54384ac893313ef738e5ad554ac328.tar
guix-4ac69ea10f54384ac893313ef738e5ad554ac328.tar.gz
Add (guix bzr-download).
* guix/bzr-download.scm, guix/build/bzr.scm, etc/snippets/scheme-mode/guix-bzr-reference: New files. * Makefile.am (MODULES): Add them. * etc/snippets/scheme-mode/guix-origin: Add "bzr-fetch" to the origin choices.
Diffstat (limited to 'guix/build/bzr.scm')
-rw-r--r--guix/build/bzr.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/guix/build/bzr.scm b/guix/build/bzr.scm
new file mode 100644
index 0000000000..86ee11391d
--- /dev/null
+++ b/guix/build/bzr.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build bzr)
+ #:use-module (guix build utils)
+ #:export (bzr-fetch))
+
+;;; Commentary:
+;;;
+;;; This is the build-side support code of (guix bzr-download). It allows a
+;;; Bazaar repository to be branched at a specific revision.
+;;;
+;;; Code:
+
+(define* (bzr-fetch url revision directory
+ #:key (bzr-command "bzr"))
+ "Fetch REVISION from URL into DIRECTORY. REVISION must be a valid Bazaar
+revision identifier. Return #t on success, else throw an exception."
+ ;; Do not attempt to write .bzr.log to $HOME, which doesn't exist.
+ (setenv "BZR_LOG" "/dev/null")
+ ;; Disable SSL certificate verification; we rely on the hash instead.
+ (invoke bzr-command "-Ossl.cert_reqs=none" "checkout"
+ "--lightweight" "-r" revision url directory)
+ (with-directory-excursion directory
+ (begin
+ (delete-file-recursively ".bzr")
+ #t)))
+
+;;; bzr.scm ends here