aboutsummaryrefslogtreecommitdiff
path: root/guix/build-system/linux-module.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-03 20:57:24 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-06 22:03:44 -0500
commitf57fbc2fb1b20823f433781d08047df5d7bc31df (patch)
treed9585b95efd042600c6d2e96951e061a25d695f2 /guix/build-system/linux-module.scm
parentb94724e8b2102be0fe9d19e9dfe44d6f7101bd4b (diff)
downloadguix-f57fbc2fb1b20823f433781d08047df5d7bc31df.tar
guix-f57fbc2fb1b20823f433781d08047df5d7bc31df.tar.gz
gnu: linux-libre: Move documentation to a separate package.
* gnu/packages/linux.scm (linux-libre-5.15-source) (linux-libre-5.10-source): Do not apply linux-libre-infodocs-target.patch. (make-linux-libre): Remove BUILD-DOC? argument, and adjust patches conditional. (make-linux-libre*): Likewise. Remove build-doc? validation. [arguments]: Move documentation related phases to the new linux-libre-documentation. [native-inputs]: Move the documentation related native inputs to linux-libre-documentation. (linux-libre-documentation): New variable. * guix/build-system/linux-module.scm (make-linux-module-builder) [arguments]: Do not delete build-doc and install-doc phases, which no longer exist for linux-libre.
Diffstat (limited to 'guix/build-system/linux-module.scm')
-rw-r--r--guix/build-system/linux-module.scm2
1 files changed, 0 insertions, 2 deletions
diff --git a/guix/build-system/linux-module.scm b/guix/build-system/linux-module.scm
index c1ddeaea10..e46195b53c 100644
--- a/guix/build-system/linux-module.scm
+++ b/guix/build-system/linux-module.scm
@@ -67,8 +67,6 @@
(lambda _
(invoke "make" "modules_prepare")))
(delete 'strip) ;faster
- (delete 'build-doc) ;costly and not useful here
- (delete 'install-doc)
(replace 'install
(lambda* (#:key inputs #:allow-other-keys)
(let ((out-lib-build (string-append #$output "/lib/modules/build")))