aboutsummaryrefslogtreecommitdiff
path: root/guix/build-system/linux-module.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-01 09:34:54 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-01 10:53:49 -0500
commit748ec628826cea3faa3679074d87fae9bc810080 (patch)
tree39366a2b057806f04c28289f40e954580042f7ad /guix/build-system/linux-module.scm
parentad9d0f8e58414749d52c2eb2c6998a0926b74388 (diff)
downloadguix-748ec628826cea3faa3679074d87fae9bc810080.tar
guix-748ec628826cea3faa3679074d87fae9bc810080.tar.gz
gnu: linux-libre: Move info manual to doc output.
The kernel Linux is installed in the system profile, which means the manual was not easily discoverable. Move it to the "doc" output, so that users can install the Linux documentation explicitly in their user profile without pulling the whole Linux package. * gnu/packages/linux.scm (make-linux-libre*) [outputs]: Conditionally add a "doc" output. [phases] {install-doc}: Install the info manual to the doc output, an create a "linux" symlink to it for convenience. * guix/build-system/linux-module.scm (make-linux-module-builder): Delete the "doc" output, if present.
Diffstat (limited to 'guix/build-system/linux-module.scm')
-rw-r--r--guix/build-system/linux-module.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/guix/build-system/linux-module.scm b/guix/build-system/linux-module.scm
index c1ddeaea10..29c3485023 100644
--- a/guix/build-system/linux-module.scm
+++ b/guix/build-system/linux-module.scm
@@ -59,6 +59,7 @@
(name (string-append (package-name linux) "-module-builder"))
(inputs
`(("linux" ,linux)))
+ (outputs (delete "doc" (package-outputs linux)))
(arguments
(substitute-keyword-arguments (package-arguments linux)
((#:phases phases)