aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:32:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:44 +0200
commitfe2e1f29b4c2eef5ebb38eb8d49395d3eec09aab (patch)
treeacba7e3ec6bd1df8083621bb73c175a41648fe27 /gnu
parent473774564a18b897aeb6d93044712034890bb3b9 (diff)
downloadguix-fe2e1f29b4c2eef5ebb38eb8d49395d3eec09aab.tar
guix-fe2e1f29b4c2eef5ebb38eb8d49395d3eec09aab.tar.gz
gnu: Add texlive-pst-rubans.
* gnu/packages/tex.scm (texlive-pst-rubans): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8c251673ea..eb0dac6f12 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33901,6 +33901,30 @@ The pulley diagrams are labelled with the physical properties of the system.")
without obscuring background colors.")
(license license:lppl1.3c)))
+(define-public texlive-pst-rubans
+ (package
+ (name "texlive-pst-rubans")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-rubans/"
+ "source/generic/pst-rubans/"
+ "tex/generic/pst-rubans/"
+ "tex/latex/pst-rubans/")
+ (base32
+ "1izpw60jm4w8xgd5aiqc7qxhjd0js1g9k9anwbpni9sn1qma66zs")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-rubans")
+ (synopsis "Draw three-dimensional ribbons")
+ (description
+ "The package uses PStricks and @code{pst-solides3d} to draw three
+dimensional ribbons on a cylinder, torus, sphere, cone or paraboloid. The
+width of the ribbon, the number of turns, the colour of the outer and the
+inner surface of the ribbon may be set. In the case of circular and conical
+helices, one may also choose the number of ribbons.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")