aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 15:22:51 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:10 +0800
commitfbb167ef77d484a5ae97539f47f3f82bc83cfcea (patch)
treea3f8554717535d5447b01e78aaf883bd30d33fe1 /gnu
parent768c185a7d067dce2de602acd3328f103c4d7908 (diff)
downloadguix-fbb167ef77d484a5ae97539f47f3f82bc83cfcea.tar
guix-fbb167ef77d484a5ae97539f47f3f82bc83cfcea.tar.gz
gnu: xdg-desktop-portal-kde: Update to 6.1.2.
* gnu/packages/freedesktop.scm (xdg-desktop-portal-kde): Update to 6.1.2. [inputs]: Remove plasma-framework, qtdeclarative-5, qtwayland-5, and kio-fuse; add libplasma, kstatusnotifieritem, qtdeclarative, and qtwayland. [propagated-inputs]: Add xdg-desktop-portal. [native-inputs]: Add python-minimal and python-pygobject. [arguments]: Set #:qtbase to qtbase. Change-Id: I492eaf242b2db5e309e53887ed92490c3c136f1a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index d7f5f82d85..222ea0fb0b 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3137,16 +3137,22 @@ interfaces.")
(define-public xdg-desktop-portal-kde
(package
(name "xdg-desktop-portal-kde")
- (version "5.27.6")
+ (version "6.1.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "0wzp21l521d9z9mnfgiapzljqpg5qc5ghyzndpr8cz54c2bf9mdf"))))
+ "0dksk5zs4w79n9l8wspwdgzx2fj1xafsjjk4d6bv2hrhhly7bnxr"))))
(build-system qt-build-system)
- (native-inputs (list extra-cmake-modules pkg-config))
+ (arguments (list
+ #:tests? #f ;; colorschemetest test fail, because require dbus.
+ #:qtbase qtbase))
+ (native-inputs (list extra-cmake-modules pkg-config
+ ;; require by test.
+ python-minimal
+ python-pygobject))
(inputs (list cups
kcoreaddons
kconfig
@@ -3155,20 +3161,22 @@ interfaces.")
kio
kirigami
knotifications
- plasma-framework
+ libplasma
plasma-wayland-protocols
+ kstatusnotifieritem
kwayland
kwidgetsaddons
kwindowsystem
kiconthemes
- qtdeclarative-5
- qtwayland-5
+ qtdeclarative
+ qtwayland
wayland
kglobalaccel
kguiaddons
libxkbcommon
- kio-fuse
wayland-protocols))
+ (propagated-inputs
+ (list xdg-desktop-portal))
(synopsis "Backend implementation for xdg-desktop-portal using Qt/KF5")
(description "This package provides a backend implementation
for xdg-desktop-portal that is using Qt/KF5.")