aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-02-04 22:02:44 -0500
committerLudovic Courtès <ludo@gnu.org>2018-02-05 16:54:27 +0100
commitfa1a17b78631681a23ae1fb7b1f902148bbebdbb (patch)
tree61e15161c5a368761c0b3dabad274b1e4b1af8ca /gnu
parent439ad15ddd532a369f44db7e86e602d33890581d (diff)
downloadguix-fa1a17b78631681a23ae1fb7b1f902148bbebdbb.tar
guix-fa1a17b78631681a23ae1fb7b1f902148bbebdbb.tar.gz
gnu: Add emacs-load-relative.
* gnu/packages/emacs.scm (emacs-load-relative): New public variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f29e28983a..9c1392a153 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3186,6 +3186,30 @@ alleviates the need for context macros, enclosing specifications or required
test tags. It supports both interactive and non-interactive use.")
(license license:gpl3+)))
+(define-public emacs-load-relative
+ (package
+ (name "emacs-load-relative")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/load-relative-"
+ version ".el"))
+ (sha256
+ (base32
+ "1hfxb2436jdsi9wfmsv47lkkpa5galjf5q81bqabbsv79rv59dps"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/rocky/emacs-load-relative")
+ (synopsis "Emacs Lisp relative file loading related functions")
+ (description
+ "Provides functions which facilitate writing multi-file Emacs packages
+and running from the source tree without having to \"install\" code or fiddle
+with @{load-path}.
+
+The main function, @code{load-relative}, loads an Emacs Lisp file relative to
+another (presumably currently running) Emacs Lisp file.")
+ (license license:gpl3+)))
+
(define-public emacs-request
(package
(name "emacs-request")