aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2024-10-25 12:46:24 +0200
committerAndreas Enge <andreas@enge.fr>2024-10-28 10:22:49 +0100
commitf85e9b104a7d1d910a8bff98f8e37b9ffbede6ed (patch)
tree00577e78397167324431bb2929470a1b76b734c1 /gnu
parent386399296a48c3ee34b9cc8d2fe08c95635a77af (diff)
downloadguix-f85e9b104a7d1d910a8bff98f8e37b9ffbede6ed.tar
guix-f85e9b104a7d1d910a8bff98f8e37b9ffbede6ed.tar.gz
gnu: prrte: Record the absolute file name of ‘prted’.
Previously a command like: guix shell --pure openmpi@5 openssh intel-mpi-benchmarks \ --with-input=openmpi@4=openmpi@5 slurm -- \ salloc -N2 -- mpirun -np 2 --map-by node IMB-MPI1 PingPong would silently fail due to ‘prted’ not being found in $PATH. * gnu/packages/parallel.scm (prrte)[arguments]: Add ‘patch-prted-reference’ phase. Change-Id: Iff30cb5a4dcc9e9cfe6638d518ee4f19561289a0 Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/parallel.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 202a98b2bc..85f8a114c3 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -727,7 +727,15 @@ commonly needed services in distributed and parallel computing systems.")
(("_ABSOLUTE")
"")
(("PRTE_CONFIGURE_CLI")
- "\"[elided to reduce closure]\"")))))
+ "\"[elided to reduce closure]\""))))
+ (add-after 'unpack 'patch-prted-reference
+ (lambda _
+ ;; Record the absolute file name of 'prted' instead of
+ ;; assuming it will be found in $PATH at run time.
+ (substitute* "src/runtime/prte_mca_params.c"
+ (("prte_launch_agent =.*")
+ (string-append "prte_launch_agent = \""
+ #$output "/bin/prted\";\n"))))))
#:disallowed-references (list (canonical-package gcc))))
(inputs (list libevent