aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-07-20 18:33:54 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-22 23:13:43 +0100
commitf7ba2b1d1ffd64c663b6f47bfd6f59b795eab96d (patch)
tree43020c89180ad748f72585618200b99342af0e02 /gnu
parent97203dbe358a4079c4d87661f3cbbbec21831e5b (diff)
downloadguix-f7ba2b1d1ffd64c663b6f47bfd6f59b795eab96d.tar
guix-f7ba2b1d1ffd64c663b6f47bfd6f59b795eab96d.tar.gz
gnu: Add go-github-com-ipfs-go-metrics-interface.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-metrics-interface): New variable. Change-Id: Ibdc97a27f873615d3ace7dbaee8709a174b783dd Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ipfs.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 1627a37812..14062e8198 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -684,6 +684,36 @@ their levels to be controlled individually.")
(list
#:import-path "github.com/ipfs/go-log"))))
+(define-public go-github-com-ipfs-go-metrics-interface
+ (package
+ (name "go-github-com-ipfs-go-metrics-interface")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-metrics-interface")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09xc71175sfnqlizkbw066jagnbag9ihvs240z6g6dm2yx3w5xgy"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-metrics-interface"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-cid
+ go-github-com-ipfs-go-datastore
+ go-github-com-multiformats-go-base32
+ go-github-com-multiformats-go-multihash))
+ (home-page "https://github.com/ipfs/go-metrics-interface")
+ ;; XXX: The project neither has no a proper description, nor a README, see
+ ;; <https://github.com/ipfs/go-metrics-interface/issues/1>.
+ (synopsis "Metrics interface for IPFS")
+ (description
+ "Metrics interface for IPFS (Kubo).")
+ (license license:expat)))
+
(define-public go-github-com-libp2p-go-socket-activation
(package
(name "go-github-com-libp2p-go-socket-activation")