aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 16:27:27 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-31 21:35:51 +0100
commitf5c8cf3be7a0a19f00cf541020fc6f37d9be2474 (patch)
treef3c77f940e9ccc7e405364e54c08075bf119079a /gnu
parentf95ebba51634e27073d2c9bf09d0b6bda1eef737 (diff)
downloadguix-f5c8cf3be7a0a19f00cf541020fc6f37d9be2474.tar
guix-f5c8cf3be7a0a19f00cf541020fc6f37d9be2474.tar.gz
gnu: Add ocaml-bin-prot.
* gnu/packages/ocaml.scm (ocaml-bin-prot): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 271fbcddaf..9a0bc91128 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2004,3 +2004,24 @@ from the oasis build log
@item a @code{js_build_tools} ocamlbuild plugin with various goodies.
@end enumerate")
(license license:asl2.0)))
+
+(define-public ocaml-bin-prot
+ (package
+ (name "ocaml-bin-prot")
+ (version "113.33.03")
+ (source (janestreet-origin "bin_prot" version
+ "1ws8c017z8nbj3vw92ndvjk9011f71rmp3llncbv8r5fc76wqv3l"))
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (build-system ocaml-build-system)
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/bin_prot/")
+ (synopsis "Binary protocol generator")
+ (description "This library contains functionality for reading and writing
+OCaml-values in a type-safe binary protocol. It is extremely efficient,
+typically supporting type-safe marshalling and unmarshalling of even highly
+structured values at speeds sufficient to saturate a gigabit connection. The
+protocol is also heavily optimized for size, making it ideal for long-term
+storage of large amounts of data.")
+ (license license:asl2.0)))