aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-28 11:07:35 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:45:05 +0300
commitf2cfc8a2497d8d7095a987e62d0e1aa7701918fe (patch)
tree482fc5325e7a5b1ce4371692f18912a8480f23c9 /gnu
parentb39b70df89972d125a5208c7aa07e4c0fa261696 (diff)
downloadguix-f2cfc8a2497d8d7095a987e62d0e1aa7701918fe.tar
guix-f2cfc8a2497d8d7095a987e62d0e1aa7701918fe.tar.gz
gnu: Add rust-async-priority-channel-0.1.
* gnu/packages/crates-io.scm (rust-async-priority-channel-0.1): New variable. Change-Id: If84476c9eecb7de7530206dedfb3d5efe469ca78
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index dfcf5fcae2..2e513c3be6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5312,6 +5312,29 @@ managing processes both synchronously (via the PidFd type) and
asynchronously (via the AsyncPidFd type).")
(license (list license:expat license:asl2.0))))
+(define-public rust-async-priority-channel-0.1
+ (package
+ (name "rust-async-priority-channel")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "async-priority-channel" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0h36m0avgs86pgh286xkvbnhdhb8bxgsnlxwwazvw88v5scph5n2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-event-listener" ,rust-event-listener-2))
+ #:cargo-development-inputs (("rust-futures-lite" ,rust-futures-lite-1)
+ ("rust-tokio" ,rust-tokio-1))))
+ (home-page "https://github.com/rmcgibbo/async-priority-channel")
+ (synopsis "Async channel with message delivery by priority")
+ (description
+ "This package provides an async channel where pending messages are
+delivered in order of priority.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-async-process-1
(package
(name "rust-async-process")