aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-06 10:52:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-06 11:21:56 +0100
commitf285346aeda1945fc14c3c4fb37c51dc1227af24 (patch)
tree4af3ed3c30791d6cc8d85cd8cee73bf53c3eebec /gnu
parent2058e37d615766774b8fdcdd02ec06a6100aac39 (diff)
downloadguix-f285346aeda1945fc14c3c4fb37c51dc1227af24.tar
guix-f285346aeda1945fc14c3c4fb37c51dc1227af24.tar.gz
gnu: Add r-tsp.
* gnu/packages/cran.scm (r-tsp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7f3363a1f4..fe40cac617 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1910,3 +1910,24 @@ standard output and error of the processes, using non-blocking connections.
@code{processx} can poll a process for standard output or error, with a
timeout. It can also poll several processes at once.")
(license license:expat)))
+
+(define-public r-tsp
+ (package
+ (name "r-tsp")
+ (version "1.1-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "TSP" version))
+ (sha256
+ (base32
+ "03xxfr5kk4zhzpb1q1pwncdp0dhchm9b48wzhvvxn2dxf3mnby2w"))))
+ (properties `((upstream-name . "TSP")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-foreach" ,r-foreach)))
+ (home-page "https://cran.r-project.org/web/packages/TSP/")
+ (synopsis "Traveling salesperson problem (TSP)")
+ (description "This package provides basic infrastructure and some
+algorithms for the @dfn{traveling salesperson problem}(TSP) (also known as the
+traveling salesman problem).")
+ (license license:gpl3)))