aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 00:15:14 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:00 +0800
commitf026cb1f1eaaf2582ad7a28af6eceaf22c67e39d (patch)
tree9627aee07d3bdeed57ab8c2c616dcf96bd16415f /gnu
parent3882035469f79e59673f42977c5b8567c6cd7a8f (diff)
downloadguix-f026cb1f1eaaf2582ad7a28af6eceaf22c67e39d.tar
guix-f026cb1f1eaaf2582ad7a28af6eceaf22c67e39d.tar.gz
gnu: ksyntaxhighlighting: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (ksyntaxhighlighting): Update to 6.3.0. [inputs]: Remove qtbase-5; add qtbase and qtdeclarative. [native-inputs]: Remove qttools-5 and qtxmlpatterns; add qttools. [arguments]: Use Gexps. Change-Id: Ica428e212c8f53125eb68abb234fc84459923a63
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6217f800cb..787b5a03a6 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1061,7 +1061,7 @@ pixel units.")
(define-public ksyntaxhighlighting
(package
(name "ksyntaxhighlighting")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1070,27 +1070,25 @@ pixel units.")
"syntax-highlighting-" version ".tar.xz"))
(sha256
(base32
- "1skblg2m0sar63qrgkjsg0w9scixggm5qj7lp4gzjn4hwq6m3n63"))))
+ "117r5nsggqnlkd8mg9l2aa00q2ns891xadxl6vxgbgk9r4shlc1q"))))
(build-system cmake-build-system)
(native-inputs
- (list extra-cmake-modules perl qttools-5
- ;; Optional, for compile-time validation of syntax definition files:
- qtxmlpatterns))
+ (list extra-cmake-modules perl qttools))
(inputs
- (list qtbase-5))
+ (list qtbase qtdeclarative))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'patch-source-shebangs 'unpatch-source-shebang
- (lambda _
- ;; revert the patch-shebang phase on scripts which are
- ;; in fact test data
- (substitute* '("autotests/input/highlight.sh"
- "autotests/folding/highlight.sh.fold")
- (((which "sh")) " /bin/sh")) ;; space in front!
- (substitute* '("autotests/input/highlight.pl"
- "autotests/folding/highlight.pl.fold")
- (((which "perl")) "/usr/bin/perl")))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'unpatch-source-shebang
+ (lambda _
+ ;; revert the patch-shebang phase on scripts which are
+ ;; in fact test data
+ (substitute* '("autotests/input/highlight.sh"
+ "autotests/folding/highlight.sh.fold")
+ (((which "sh")) " /bin/sh")) ;; space in front!
+ (substitute* '("autotests/input/highlight.pl"
+ "autotests/folding/highlight.pl.fold")
+ (((which "perl")) "/usr/bin/perl")))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Syntax highlighting engine for Kate syntax definitions")
(description "This is a stand-alone implementation of the Kate syntax